Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46689 - [gnome-settings-daemon] Power button wrong behavior since I upgraded to Gnome 3.18

Attached to Project: Arch Linux
Opened by Luca Viggiani (lviggiani) - Tuesday, 13 October 2015, 07:50 GMT
Last edited by Jan de Groot (JGC) - Friday, 30 September 2016, 10:17 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Before upgrading to gnome 3.18, the power button was set (and working) as shutdown. That was set via the gnome tweak tool.

After I upgraded to gnome 3.18 it started working as "suspend".

In gnome tweak tool, the option to change it's behavior is not shown anymore.

I have also checked with dconf-editor the value of "org/gnome/settings-daemon/power-button" and if shows "shutdown" (as expected) but it behaves as "suspend" anyway.

Finally, in "/etc/systemd/logind.conf", "HandlePowerKey" is commented out. Uncommenting and setting it as shutdown (and restarting) does not change anyway (still "suspend").

Today I got the update of gnome-setting-daemon package to 3.18.1, but the issue is still there.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 30 September 2016, 10:17 GMT
Reason for closing:  Upstream
Additional comments about closing:  Upstream decision.
Comment by Luca Viggiani (lviggiani) - Tuesday, 13 October 2015, 08:30 GMT
I forgot to mention that this happens on a Dell XPS 13 (Ivybridge) laptop.
Comment by Luca Viggiani (lviggiani) - Tuesday, 13 October 2015, 13:19 GMT
I found out that a discussion is already ongoing here:
https://bugzilla.gnome.org/show_bug.cgi?id=755953
Comment by Realex (Realex) - Wednesday, 14 October 2015, 12:53 GMT
I confirm the problem. PC: motherboard - asus p7p55lx.
Comment by Realex (Realex) - Friday, 16 October 2015, 08:07 GMT
As a temporary solution can delete this —Āommit. ( https://git.gnome.org/browse/gnome-settings-daemon/commit/?id=50564cd )

Loading...