Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46686 - [pulseaudio-bluetooth] registers multiple ad2p sinks with bluez.

Attached to Project: Arch Linux
Opened by john doe (jatone) - Monday, 12 October 2015, 21:57 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Sunday, 20 February 2022, 04:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: multiple A2DP Sources/Sinks get registered with bluetooth at the same rfcomm port.


package version: 7.0.2
journalctl -f --unit=bluetooth
Oct 12 17:47:54 jambli bluetoothd[2006]: Endpoint registered: sender=:1.142 path=/MediaEndpoint/A2DPSource
Oct 12 17:47:54 jambli bluetoothd[2006]: Endpoint registered: sender=:1.142 path=/MediaEndpoint/A2DPSink
Oct 12 17:47:54 jambli bluetoothd[2006]: Endpoint registered: sender=:1.51 path=/MediaEndpoint/A2DPSource
Oct 12 17:47:54 jambli bluetoothd[2006]: Endpoint registered: sender=:1.51 path=/MediaEndpoint/A2DPSink
Oct 12 17:47:54 jambli bluetoothd[2006]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)

error disappears when one removes pulseaudio-bluetooth and restarts pulseaudio and bluetooth.


Steps to reproduce:
sudo systemctl restart bluetooth
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Sunday, 20 February 2022, 04:00 GMT
Reason for closing:  No response
Additional comments about closing:  2022-02-18: A task closure has been requested. Reason for request: Stale since 2015-10-13, 1 day after its submission. Issue has not even been verified. I for one never had the mentioned issue since 2019 when I started using Arch-based Manjaro with pulseaudio-bluetooth.

Loading...