Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46678 - [gtk3] Memory card does not appear in Nautilus

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Monday, 12 October 2015, 14:29 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 10 November 2015, 14:23 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello!

Description:
Nautilus doesn't shows automatically mounted memory cards on the sidebar, if the card reader isn't known to be ejectable (e.g. PCI-Express based card readers on most ThinkPads). The bug is inside GTK's new GTKPLACESIDEBAR. As a side effect, no notifications about the successful mounting is shown. Users have to recognized itself that the memory cards are mounted successfully and have to navigate themselfes to the mountpoint e.g. '/run/media/$USER/$FS_LABEL', furthermore they have to umount the memory cards itself or the filesystem could be damaged.

Card readers which are connected through USB shouldn't be affected.

Additional info:
* package version(s): gtk3 3.18.1-1
* upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=755654
* config and/or log files etc.:
mmc_sd.patch # from upstream, not yet in git/svn
PKGBUILD # with patch


Steps to reproduce:
1. Laptop with card reader which is not connected through USB, e.g. ThinkPads (X220, T420 and so on) which use PCI-Express to connect it's card readers
2. Plugin any type of SD-Card
3. Card is mounted but no added to Sidebar, no notifications about successfull mount

I suggest to wait until the patch get's an officiall approval by upstream and is commited to their git repository. Subsequently we can push out a new PKGRELEASE? The filesystem on a memory card could be easly damaged, because Nautilus doesn't offer any option to safely unmount the memory card.

Thank you

PS: If your memory card is formatted with FAT a 'fsck.msdos /dev/$PATH_TO_DEVICE' executed as root will remove the dirty bit.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 10 November 2015, 14:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk3 3.18.3-1
Comment by Peter Weber (hoschi) - Thursday, 15 October 2015, 08:08 GMT
Pushed to master by upstream: https://git.gnome.org/browse/gtk+/commit/?id=f2b848a5319987a3b45282058cd091b3e3152652

// edit
-- if the card reader isn't known to be ejectable
++ if the card reader isn't known to be able to eject the inserted "media"

Yes. That "eject" thing is weird, because it doesn't mean the "push-push ejector" but more the eject from cdrom-drives.

Loading...