Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46638 - [xf86-video-intel] Graphical corruption - entire screen reverts to previous frame

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Saturday, 10 October 2015, 04:46 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 10 October 2015, 12:52 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

With the update to xf86-video-intel 1:2.99.917+478+gdf72bc5-1 in testing, there is heavy graphical corruption in which the whole screen seems to frequently revert to the previous frame that was drawn, with curious effects: popup windows show for a split second and then disappear again, terminal sessions scroll down after executing a command and then immediately scroll back up again, and so on.

Downgrading to xf86-video-intel 1:2.99.917+472+gf0fd4d5-1 from extra fixes the problem.

Steps to reproduce:

1. Log into XFCE with compton.
2. Open some popup menus.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 10 October 2015, 12:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  xf86-video-intel-1:2.99.917+478+gdf72bc5 -2
Comment by James (Raziel23) - Saturday, 10 October 2015, 06:41 GMT
The cause is setting DRI3 as default, but it shouldn't be set in the near future because of this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=81551
Comment by Laurent Carlier (lordheavy) - Saturday, 10 October 2015, 07:09 GMT
please check with xf86-video-intel-1:2.99.917+478+gdf72bc5-2

Loading...