Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46609 - [kglobalaccel kwallet plasma-workspace kdebase-runtime kded] Allow support of systemd user units

Attached to Project: Arch Linux
Opened by AnAkkk (AnAkkk) - Thursday, 08 October 2015, 15:19 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 08 October 2015, 16:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Systemd user units for the Plasma session have been available for a while now, and I have been using them every day for months without any issues. They're supposed to be included in upstream package, as you can see they're available in KDE git, under a different repository for now though:
https://quickgit.kde.org/?p=plasma-systemd-integration.git

An AUR package is also available, which I'm now maintainer of:
https://aur.archlinux.org/packages/plasma-workspace-units-git

The problem is that there are 5 files which are conflicting because they already exist in kglobalaccel, kwallet, plasma-workspace, kdebase-runtime and kded.
The only difference is the addition of a SystemdService= line at the end of each file. This line is only used when using the systemd session, it doesn't hurt to add it, so it could safely be added to the packages right now, as can be seen in these files:

kded: https://quickgit.kde.org/?p=plasma-systemd-integration.git&a=blob&h=549bf03a69fe4e2bb62c6be48b957a30bbecfa71&f=dbus%2Fservices%2Forg.kde.kded5.service&o=plain
kglobalaccel: https://quickgit.kde.org/?p=plasma-systemd-integration.git&a=blob&h=3b7adf9f0119b85165ebfb1d70dc2ae20759db74&f=dbus%2Fservices%2Forg.kde.kglobalaccel.service&o=plain
plasma-workspace: https://quickgit.kde.org/?p=plasma-systemd-integration.git&a=blob&h=736d1fe7a036f3d4bcec3d3c9b8144a481b34fc5&f=dbus%2Fservices%2Forg.kde.krunner.service&o=plain
kdebase-runtime: https://quickgit.kde.org/?p=plasma-systemd-integration.git&a=blob&h=3bac2ad97a46c391e78cd9a966b43cd211fc407a&f=dbus%2Fservices%2Forg.kde.kuiserver.service&o=plain
kwallet: https://quickgit.kde.org/?p=plasma-systemd-integration.git&a=blob&h=bbc260b3a1da91fc1b7a32ef8362b510a3a5687d&f=dbus%2Fservices%2Forg.kde.kwalletd5.service&o=plain

If this is added, I can then remove the files from the plasma-workspace-units-git package, making it work without any conflicts.
Using the package bring a real improvement, when I'm not using it I have to wait 10+ seconds on the KDE splash screen, and while using it everything launch in less than 2 seconds.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 08 October 2015, 16:24 GMT
Reason for closing:  Upstream
Additional comments about closing:  This should be committed upstream
Comment by Bhushan Shah (bhushan_shah) - Thursday, 08 October 2015, 15:25 GMT
I highly object against putting this in here..

Please send patches to KDE repositories.
Comment by AnAkkk (AnAkkk) - Thursday, 08 October 2015, 15:26 GMT
Weren't you or Elias Probst going to send the patches?
Comment by Bhushan Shah (bhushan_shah) - Thursday, 08 October 2015, 15:28 GMT
Right, however I haven't managed to find time due to my job.. :(
Comment by Bhushan Shah (bhushan_shah) - Thursday, 08 October 2015, 15:32 GMT
One of reason I object against is, there is service name conflict in kuiserver5 and if this is commited it will render session useless..
Comment by AnAkkk (AnAkkk) - Thursday, 08 October 2015, 15:56 GMT
What do you mean by useless? I'm not seeing any issues... is there a way to solve this conflict though?
Comment by Antonio Rojas (arojas) - Thursday, 08 October 2015, 16:18 GMT

Loading...