Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46590 - [kdepim-runtime] akonadi_kalarm_resource segfaults every time kalarm displays an alarm

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Tuesday, 06 October 2015, 21:41 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 07 October 2015, 18:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

akonadi_kalarm_resource segfaults every time kalarm displays an alarm.

Seems like this only started happening recently, since I upgraded to 15.07


Additional info:
* package version(s)

15.08.1-4


* config and/or log files etc.

Unknown


Steps to reproduce:

1) Create a display alarm in Kalarm, for say 1 minute from now.
2) Wait 1 minute.
3) Kalarm shows the alarm ... along with a drkonqi window indicating that akonadi_kalarm_resource segfaulted

This happens every time an alarm is shown. (And I think other times that I interact with kalarm as well.)
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 07 October 2015, 18:46 GMT
Reason for closing:  None
Comment by Antonio Rojas (arojas) - Tuesday, 06 October 2015, 22:00 GMT
Please report this upstream
Comment by David Rosenstrauch (darose) - Wednesday, 07 October 2015, 15:54 GMT
I think I've (at least temporarily) found a cause and managed to make the issue go away.

It seems like for some reason the configuration in kalarm's "show calendars" section got screwed up. I'm not sure how/why, as the .ics files stored in ~/.local/share/kalarm were all fine. But nevertheless something in the show calendars section was screwed up, as I couldn't successfully edit the "Active Alarms" entry. I created a "New Active Alarms" item and made that the default (and same with "Archived Alarms") and that got everything working again. But I'm not sure what went wrong in the first place. I'm guessing that's an Akonadi issue, as I think those calendar entries get stored in the Akonadi database somewhere.
Comment by Antonio Rojas (arojas) - Wednesday, 07 October 2015, 18:46 GMT
OK thanks. If it happens again, report upstream with a backtrace

Loading...