Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46583 - [lxmusic] undefined symbol: xmmsc_result_notifier_set_full

Attached to Project: Community Packages
Opened by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 11:13 GMT
Last edited by Balló György (City-busz) - Sunday, 08 November 2015, 05:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
It looks like lxmusic-0.4.6-1 misses a dependency.
In some environments the application launches normally, while e.g. in two of my installs, one fluxbox, one i3 it fails with:

$ lxmusic
lxmusic: symbol lookup error: lxmusic: undefined symbol: xmmsc_result_notifier_set_full
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 08 November 2015, 05:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  lxmusic 0.4.6-2
Comment by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 11:54 GMT
Installed lxmusic-gtk3-0.4.6-2 (AUR) now, and that one works!
Comment by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 12:58 GMT
Maybe the problem is gtk2 related. The patches of the AUR-packages are not suggesting any other differences as far as I can see.
I am currently using gtk2 2.24.28-1
Comment by Doug Newgard (Scimmia) - Tuesday, 06 October 2015, 16:07 GMT
What version of xmms2?
Comment by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 16:36 GMT
$ pacman -Qi xmms2
Name : xmms2
Version : 0.8DrO_o.882.g942b17f-2
Comment by Doug Newgard (Scimmia) - Tuesday, 06 October 2015, 16:47 GMT
And is it the same version on the ones that work?
Comment by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 17:12 GMT
one working has 0.8DrO_o-35
Comment by Doug Newgard (Scimmia) - Tuesday, 06 October 2015, 23:09 GMT
So lxmusic probably just needs a simple rebuild.
Comment by Bernhard Landauer (oberon) - Tuesday, 06 October 2015, 23:19 GMT
Hah! You are absolutely right :D I just built it with your PKGUILD and it works perfectly fine! ;) Thank you.
Comment by Holmes Linux (Holmes) - Friday, 09 October 2015, 10:06 GMT
i am having this problem: lxmusic: symbol lookup error: lxmusic: undefined symbol: xmmsc_result_notifier_set_full.
by what i was told the package needs to be rebuilt because the xmms is a new version...
Comment by Vanush "Misha" Paturyan (ektich) - Wednesday, 14 October 2015, 09:44 GMT
When will the rebuilt package hit the servers?

Loading...