Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46536 - [avahi] daemon is spamming the logs.

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Friday, 02 October 2015, 12:25 GMT
Last edited by freswa (frederik) - Monday, 28 September 2020, 20:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Avahi daemon is spamming the logs with about 20-30 lines per second with the following message:

Out 02 13:06:07 VoidCaster avahi-daemon[423]: Invalid response packet from host 10.100.230.123.

The IP address changes on every message.
This has only started to occur as of avahi 0.6.31-17 (at least as far as I can tell. My logs have rotated a lot today since they grow huge very quickly)

Additional info:

Seems to be present on other distros too[1], but a little extra weight from arch should help "persuade" upstream to apply a patch that has been floating around for a while[2].
Or maybe (and I know this is against "the arch way") the arch package could be patched?
Thanks!

Steps to reproduce:
Run avahi daemon when there is a machine running OSX in your network and you will get this spammed in your logs.

[1] https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/1342400
[2] http://lists.freedesktop.org/archives/avahi/2012-July/002171.html
This task depends upon

Closed by  freswa (frederik)
Monday, 28 September 2020, 20:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  avahi 0.6.32rc-1
Comment by Francisco Pina (Stunts) - Wednesday, 07 October 2015, 21:36 GMT
Potential patch available here:
https://github.com/lathiat/avahi/issues/10
Just in case.
Comment by Bastien Traverse (Neitsab) - Tuesday, 20 October 2015, 16:45 GMT
Since the last update it isn't even possible to stop/disable avahi-daemon anymore to prevent the flooding: dbus (1.10.0-3 -> 1.10.0-4) is consistently reactivating avahi:

oct. 20 18:37:57 hostname sudo[3981]: neitsab : TTY=pts/1 ; PWD=/home/neitsab ; USER=root ; COMMAND=/usr/bin/systemctl stop avahi-daemon.service avahi-daemon.socket
oct. 20 18:37:57 hostname sudo[3981]: pam_unix(sudo:session): session opened for user root by (uid=0)
oct. 20 18:37:57 hostname polkitd[776]: Registered Authentication Agent for unix-process:3982:1434368 (system bus name :1.128 [/usr/bin/pkttyagent --notify-fd 4 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.utf8)
oct. 20 18:37:57 hostname avahi-daemon[3953]: Got SIGTERM, quitting.
oct. 20 18:37:57 hostname systemd[1]: Stopping avahi-daemon.service...
oct. 20 18:37:57 hostname avahi-daemon[3953]: Leaving mDNS multicast group on interface virbr0.IPv4 with address 192.168.122.1.
oct. 20 18:37:57 hostname systemd[1]: Closed avahi-daemon.socket.
oct. 20 18:37:57 hostname avahi-daemon[3953]: Leaving mDNS multicast group on interface wlp2s0.IPv6 with address 2001:41d0:xxxx:xxxx::.
oct. 20 18:37:57 hostname systemd[1]: Stopped avahi-daemon.service.
oct. 20 18:37:57 hostname avahi-daemon[3953]: Leaving mDNS multicast group on interface wlp2s0.IPv4 with address 192.168.1.80.
oct. 20 18:37:57 hostname avahi-daemon[3953]: avahi-daemon 0.6.31 exiting.
oct. 20 18:37:57 hostname sudo[3981]: pam_unix(sudo:session): session closed for user root
oct. 20 18:37:57 hostname dbus[712]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
oct. 20 18:37:57 hostname systemd[1]: Starting Avahi mDNS/DNS-SD Stack...

And then the flood resumes. I've tried masking both units (service and socket), to no avail.
Comment by loqs (loqs) - Monday, 28 September 2020, 20:15 GMT

Loading...