Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46494 - [linux] 4.2.1-1 no ACPI battery

Attached to Project: Arch Linux
Opened by Mark Weiman (markzz) - Wednesday, 30 September 2015, 13:55 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 14 October 2017, 15:01 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: ACPI battery no longer being detected at boot in linux 4.2. Only when plugging in the AC adaptor or closing the laptop lid will the battery indicator in desktops will show. When downgrading to 4.1.6-1 or using linux-lts, the problem is no longer present.


Additional info:
* linux 4.2.1-1


Steps to reproduce:
Upgrade to linux 4.2.1-1 and reboot.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 14 October 2017, 15:01 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 30 September 2015, 14:17 GMT
You will need to provide more information...

Please attach dmesg output from working and non-working versions.
Comment by Mark Weiman (markzz) - Wednesday, 30 September 2015, 16:50 GMT
Attached are as follows:

linux41-full: full dmesg output on linux 4.1.6-1
linux41-acpi: dmesg piped into grep on linux 4.1.6-1 (grep -i acpi)
linux42-full: full dmesg output on linux 4.2.1-1
linux42-acpi: dmesg piped into grep on linux 4.2.1-1 (grep -i acpi)
Comment by Mark Weiman (markzz) - Tuesday, 08 March 2016, 18:09 GMT
Issue still present in 4.4.3-1. Appeared in one of the more recent linux-lts releases.
Comment by Nathaniel (bruffalobill) - Saturday, 16 April 2016, 13:27 GMT
I have had a similar issue on a Dell Inspiron 14 7437. I solved this by building my own kernel using ABS and adding 'CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y' to my .config.

I also had to add 'acpi_rev_override' as a kernel command line argument. I do not have a full understanding on how this changes how the kernel interacts with the hardware, but it seems to work so I am happy with that. This thread is originally what pointed me in the right direction http://ubuntuforums.org/archive/index.php/t-2308941.html.

I have attached my current .config to this post. Although I only made a change to the CONFIG_ACPI_REV_OVERRIDE_POSSIBLE line.

Let me know if you need any other details.


Comment by Mark Weiman (markzz) - Saturday, 16 April 2016, 14:35 GMT
It looks like Ubuntu has that compiled in their generic kernel, could this be included in Arch's?

Also thanks, I assume this will work on my 7537 and this has been bugging me for some time now (especially since linux-lts has the same problem now).
Comment by Nathaniel (bruffalobill) - Sunday, 17 April 2016, 10:12 GMT
This could very easily be implemented into the arch kernel, however that is up to the arch devs. As a workaround have a look at the wiki page on using abs to build your own arch kernel.
Comment by Mark Weiman (markzz) - Sunday, 17 April 2016, 15:05 GMT
I'm very aware of how to use the abs and how to build my own packages. I only made a suggestion that it be put in the ARCH kernel.
Comment by Mark Weiman (markzz) - Wednesday, 27 April 2016, 21:11 GMT
A new problem comes up when using this that the wireless card becomes disabled when you unplug the AC cable and requires a restart in order for that to come back on when acpi_rev_override is used. Perhaps there's another solution.
Comment by Nathaniel (bruffalobill) - Thursday, 28 April 2016, 06:39 GMT
I have not experienced issues with the wifi card disabling. But have had issues with bluetooth. I found that the issue was caused by the systemd service "systemd-modules-load.service" which was not loading. The message returned from this service was "Failed to find module 'acpi_call'". After installing acpi_call from the community repository, this issue was resolved. I am unsure if this will work in your case, however it may be worth a try.
Comment by Mark Weiman (markzz) - Thursday, 28 April 2016, 21:51 GMT
systemd-modules-load.service loads with no problems. Then when I install acpi_call, the unit fails and there is no effect on the problem.
Comment by mattia (nTia89) - Monday, 02 October 2017, 20:11 GMT
is this issue still valid?
Comment by Mark Weiman (markzz) - Monday, 02 October 2017, 20:23 GMT
Yes.
Comment by mattia (nTia89) - Monday, 02 October 2017, 20:24 GMT
is it valid with latest kernel?
Comment by Mark Weiman (markzz) - Monday, 02 October 2017, 21:34 GMT
It appears no actually, but it did sometimes magically work just fine on some boots. I'll watch the next few boots to see if it continues to work.

Loading...