Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46470 - [gconf] Can't find gconfpkg in /usr/sbin/gconfpkg

Attached to Project: Arch Linux
Opened by Heat Freeze (H. Freeze) - Tuesday, 29 September 2015, 08:51 GMT
Last edited by Allan McRae (Allan) - Tuesday, 29 September 2015, 10:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Some packages like nautilus-actions and nautilus-open-terminal look for 'gconfpkg' in '/usr/sbin/gconfpkg' during install and are unable to find it as it exists in '/usr/bin/gconfpkg'. The problem could simply be avoided by adding a symlink from '/usr/bin/gconfpkg' '/usr/sbin/gconfpkg'

Additional info:

* package version(s)
gconf 3.2.6-3
nautilus-actions 3.2.4-1
nautilus-open-terminal-0.20-2


* config and/or log files etc.

Installation Log :

( 6/11) installing nautilus-open-terminal [########################################################] 100%
/tmp/alpm_IvYWNg/.INSTALL: line 4: usr/sbin/gconfpkg: No such file or directory
error: command failed to execute correctly

( 8/11) installing nautilus-actions [########################################################] 100%
/tmp/alpm_KzyAa2/.INSTALL: line 4: usr/sbin/gconfpkg: No such file or directory


Steps to reproduce:

Install nautilus-actions and nautilus-open-terminal
sudo pacman -S nautilus-actions nautilus-open-terminal


Possible Solution:
Make a symlink from '/usr/bin/gconfpkg' '/usr/sbin/gconfpkg'

ln -s /usr/bin/gconfpkg /usr/sbin/gconfpkg
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 29 September 2015, 10:56 GMT
Reason for closing:  Not a bug
Comment by Evangelos Foutras (foutrelis) - Tuesday, 29 September 2015, 10:34 GMT
The filesystem package already contains a /usr/sbin symlink that points to the bin directory.

This was implemented two years ago so there's something wrong with your installation. [1]

[1] https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/
Comment by Heat Freeze (H. Freeze) - Tuesday, 29 September 2015, 10:51 GMT
Thanks for clarification. Reinstalling filesystem after removing /usr/sbin seems to resolve this. Marking it for closure.

Loading...