Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46447 - [cmus] 2.7.1-2 hangs on start

Attached to Project: Community Packages
Opened by kebolio (ybkbolio) - Saturday, 26 September 2015, 18:15 GMT
Last edited by Xyne (Xyne) - Saturday, 21 September 2019, 13:14 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Xyne (Xyne)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: cmus 2.7.1-2 simply hangs on startup with no output on stdout/stderr.

Additional info:
* cmus version 2.7.1-2 (only a change in the PKGBUILD to rebuild for ncurses 6.0).
* libpulse version 7.0-1. I don't use PulseAudio on my system if it matters.
* glibc version 2.22-3.
* ncurses version 6.0-3.
* I rebuilt the package from ABS with options=(debug !strip) to obtain a trace.
* cmus 2.7.1-1 from the Arch rollback machine crashes with not being able to find libncursesw.5 obviously because there is a new version of ncurses.

Steps to reproduce:
1. Install cmus 2.7.1-2.
2. Run it in terminal.
This task depends upon

Closed by  Xyne (Xyne)
Saturday, 21 September 2019, 13:14 GMT
Reason for closing:  Upstream
Additional comments about closing:  Maybe fixed? Report upstream if not.
Comment by Tyler (luckdragon) - Tuesday, 29 September 2015, 23:28 GMT
After reading this bugreport I downloaded and compiled cmus 2.6.2 (https://github.com/cmus/cmus/archive/v2.6.2.tar.gz) from source on a machine affected by this bug and it had the same problem.

I also only have ALSA installed, everything the same as above but libpulse version 7.0-2
Comment by Xyne (Xyne) - Thursday, 08 October 2015, 15:00 GMT
While investigating this I noticed that cmus 2.7.1-2 starts normally on my computer using one user account but not another. After some testing it seems that cmus requires a file names ~/.cmus/autosave with the following line:

set output_plugin=alsa

Add that line to your autosave file if it exists, otherwise create it with

echo 'set output_plugin=alsa' > ~/.cmus/autosave

Let me know if this solves the issue. If anyone has a cleaner solution, please share.
Comment by Theodor (ttheodor) - Friday, 09 October 2015, 18:20 GMT
I have the same problem on a fresh Arch installation.

Doing echo 'set output_plugin=alsa' > ~/.cmus/autosave prevented cmus from hanging but it's still unusable. The only only thing that cmus responds to is pressing :(command). 1-7, arrow keys, etc don't have an effect.
Comment by kebolio (ybkbolio) - Saturday, 10 October 2015, 09:47 GMT
After I reinstalled Arch on my system, cmus works perfectly for whatever reason.

I thought that because it was hanging on a thread library it would be a problem of glibc or something
Comment by s1gma (s1gma) - Thursday, 12 November 2015, 14:00 GMT
Rebuilding cmus from ABS with "./configure prefix=/usr CONFIG_PULSE=n" solves the problem for me, so I guess the issue is with libpulse 7 (7.1-1 on my machine).

The bug has popped on github too: https://github.com/cmus/cmus/issues/337.
Comment by Ebrahim Azarisooreh (eazar001) - Tuesday, 29 December 2015, 08:16 GMT
I can confirm @s1gma's solution works.
Comment by Justin McCormick (karcadia) - Monday, 18 April 2016, 19:27 GMT
echo 'set output_plugin=alsa' > ~/.cmus/autosave

This fixes the failure to launch problem, and after first launch, cmus will add a bunch of config to the autosave file, but for whatever reason, it misses *all* of the keybindings, so after the first launch of cmus, close it again and add this to the autosave file:

(Note: Not sure how much it matters but I paste all these bindings on the line above factivate)

http://pastebin.com/QRr735b9
Comment by Gregory Petrosyan (pgregory) - Monday, 31 October 2016, 19:43 GMT
Please do not edit `autosave` file, it is managed by cmus itself. That's why keybindings etc. are missing.
User settings should go to `rc` file (next to `autosave`).
Comment by John Doe (Larivact) - Monday, 06 February 2017, 06:09 GMT
So the best fix currently is:

mkdir ~/.cmus; echo 'set output_plugin=alsa' > ~/.cmus/rc
Comment by Michael Straube (arisinfenix) - Sunday, 15 September 2019, 13:51 GMT
Is this still an issue with cmus 2.8.0-3 ?
Comment by Xyne (Xyne) - Saturday, 21 September 2019, 13:14 GMT
Not sure but even if it is, it's an upstream issue.

Closing.

Loading...