Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46436 - [libreoffice-still] 4.4.5-2 crashes at startup without GTK [2|3]

Attached to Project: Arch Linux
Opened by Daniel Mirkin (DanielH) - Friday, 25 September 2015, 15:08 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 05 February 2016, 17:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Evangelos Foutras (foutrelis)
Antonio Rojas (arojas)
Bartłomiej Piotrowski (Barthalion)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
libreoffice-still 4.4.5-2 crashes at startup without GTK[2|3] installed (NOTE: gtk2|3 are OPTIONAL dependencies for GTK integration).

Launching LO from dmenu or from terminal brings me its splash window and progress bar, then shows its Welcome window.
Clicking on any menu or Create button (Writer document, Calc spreadsheet, and so) immediately closes Welcome window, showing only the LO Document Recovery window without any file in it. Accepting by OK button closes that window and then relaunches LO automatically.
Clicking on Open file button shows LO Open dialog window, allowing to select any file, navigate the system hierarchy, etc.; but clicking Open button repeats previous described behavior.

Installing gtk2: LO works as expected.

Additional info:
* package version(s):
libreoffice-still 4.4.5-2

* config and/or log files etc.
/etc/profile.d/libreoffice-still.sh
# to force a certain look'n feel

export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=kde4
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

Other logs: LO and gtk2 dependencies, backtrace, strace: look at attached libreoffice-still 4.4.5-2_crashes_without_gtk.txt

Steps to reproduce:
1. Arch Linux installed without GTK[2|3] nor GTK dependencies; only window manager (dwm), menu (dmenu), and pure Qt apps (not KDElibs dependencies).
2. Install libreoffice-still 4.4.5-2.
3. Launch LO from virtual terminal (urxvt-unicode) or from dmenu.
4. At LO Welcome screen, click on any menu or in New (Calc, Writer, etc.) document button: LO crashes showing empty Document Recovery screen; clicking on OK button closes that screen and relaunches LO (see topic at Arch forum: https://bbs.archlinux.org/viewtopic.php?id=202172 ).
5. Install gtk2 and its dependencies and launch LO from terminal or menu: LO works fine.
6. Remove ONLY gtk2, keeping its dependencies: LO crashes.
7. Remove gtk2 AND its dependencies: LO crashes.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 05 February 2016, 17:47 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 November 2015, 17:52 GMT
Please test with kde integration. Then gtk2 shouldn't be required. I guess we need to change to something like:

"gtk2: for GTK2 integration and generic vcl".
Comment by Andreas Radke (AndyRTR) - Thursday, 31 December 2015, 09:13 GMT
The situation has become worse now.

- Gtk2 and generic vcl work well, gtk2 is a dependency of both but technically not a hard dependency of libreoffice at all.
- Gtk3 vcl is broken in 5.0.x
- kde4 vcl is buggy and disabled by upstream if unpatched qt4 is detected due to the not pachted qt4 ( FS#41648  and  FS#39819 )

So the only user option is to depend on gtk2 that currently is only a optional dependency leading to users seeing crashes like here:
https://bbs.archlinux.org/viewtopic.php?pid=1590914

Qt devs didn't apply the required patches from their tracker into the 4.8.7 release. No idea why. This means in the Arch way to not apply the patches because usually upstream decides what patches are proper fixes. In this case I'd like to break our rule and think it makes sense to apply the qt4 patches to our qt4 packages and then rebuild both LibO versions (-still and -fresh). That way we get kde4 vcl integration back to LibreOffice and can keep gtk2 an optional dependency. And with LibO-fresh 5.1.x I hope to get back also the gtk3 vcl into a working status.

Any objections from our qt4 maintainers applying the patches? The patches are widely used in other distributions and should not break anything, e.g. http://pkgs.fedoraproject.org/cgit/qt.git/tree/qt.spec
* Sat Jun 07 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.8.6-9
- apply proposed fixes for QTBUG-34614,37380,38585 for LibreOffice (#1105422)

Can I go ahead and patch qt4? Adding some devs here who touched qt4 lately.
Comment by Andreas Radke (AndyRTR) - Friday, 01 January 2016, 08:53 GMT
Patches have been applied to qt4. Try LibO-still 4.4.7-3 and LibO-fresh 5.0.4-3.

So now kdelibs should be a valid alternative to gtk2 and so gtk2 might stay an optional dependency. I have no gtk2-less system around for testing.

Can somebody affected please test if kdelibs with kde4 vcl works well without gtk2 installed? If it still requires gtk2 we would need to
make gtk2 a true runtime dependency. With LibO-still you can also try with gtk3 vcl though this is known to be highly unstable.
Comment by Jesse McClure (Trilby) - Monday, 11 January 2016, 16:48 GMT
Andreas, thanks for opening this bug.

I just tested with kdelibs installed, and LO still fails unless gtk2 is *also* installed as described here:
https://bbs.archlinux.org/viewtopic.php?pid=1594409#p1594409

The libreoffice website now seems to indicate that gtk2 (or higher) is required regardless of which toolkit one wishes to use:
https://www.libreoffice.org/get-help/system-requirements/#Linux

GTK2 or higher is required. On top of that one can use gnome, or kde for desktop integration.

I believe gtk2 should be listed as a (not optional) dependency for libreoffice.
Comment by Andreas Radke (AndyRTR) - Monday, 11 January 2016, 19:06 GMT
I'll add gtk2 to the true runtime deps. Is this valid for LibO-still and -fresh branch?

Loading...