Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46417 - [system-config-printer] Multiple instances of applet.py running concurrently

Attached to Project: Arch Linux
Opened by Charles Bos (Chazza) - Thursday, 24 September 2015, 08:35 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 20 November 2015, 14:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the upgrade of the following packages:

[2015-09-21 11:34] [ALPM] upgraded libsystemd (225-1 -> 226-1)
[2015-09-21 11:34] [ALPM] upgraded libdbus (1.10.0-2 -> 1.10.0-3)
[2015-09-21 11:34] [ALPM] upgraded dbus (1.10.0-2 -> 1.10.0-3)
[2015-09-21 11:34] [ALPM] upgraded systemd (225-1 -> 226-1)
[2015-09-21 11:34] [ALPM] upgraded systemd-sysvcompat (225-1 -> 226-1)

I have noticed behaviour whereby a new instance of applet.py is started on every login and the old instances are not killed off on logout, meaning that after several logins, several instances of applet.py will be running concurrently.

Downgrading the aforementioned packages makes this issue disappear. Also, adding pkill applet.py to my ~/.xprofile works as a workaround.

I'm using Xfce4 and LightDM.

Additional info:
* package version(s)
(dbus and systemd packages shown above)
system-config-printer 1.5.7-1
lightdm 1:1.16.2-1
xfce4-session 4.12.1-2

Steps to reproduce:
Upgrade the dbus and systemd packages as shown above. Then, ensuring that applet.py will be autostarted by the desktop environment, log out and in again multiple times. Multiple instances of applet.py will be running
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 20 November 2015, 14:17 GMT
Reason for closing:  None
Additional comments about closing:  User requested
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 November 2015, 17:47 GMT
If this is still an issue please check if it is also present in a recent system-config-printer git pkg or ask upstream/file a bug/post to its mailing list.
Comment by Charles Bos (Chazza) - Friday, 20 November 2015, 13:42 GMT
I can no longer reproduce the issue.

Loading...