Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46415 - [linux] Constant kernel panics with linux 4.1.6-1 using MD RAID5

Attached to Project: Arch Linux
Opened by Curtis Lee Bolin (curtisleebolin) - Thursday, 24 September 2015, 06:18 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 27 September 2015, 04:38 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I kept getting immediate kernel panics when I would tax my MD RAID5 hard. I filed a bug report for it at https://bugzilla.kernel.org/show_bug.cgi?id=104921 . I got a quick reply from Neil Brown with some Commits that haven't been added to a 4.1.x release yet. I generated some patches from the Commits, added them to the PKGBUILD, built, and tried the kernel out. It solved the problem on all 3 of my servers. Can we get these patches into the linux package because this was a work stopping bug?

Additional info:
linux 4.1.6-1

Steps to reproduce:
Large file transaction on a MD RAID5 volume.

Attachments:
I attached the journal of the kernel panic and the 2 patches that resolved my problem.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 27 September 2015, 04:38 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#46002 
Comment by Doug Newgard (Scimmia) - Thursday, 24 September 2015, 13:21 GMT
Is this solved in 4.2? Doesn't make sense to patch 4.1 when 4.2 will be moving to Core at some point if that fixes it.
Comment by Curtis Lee Bolin (curtisleebolin) - Thursday, 24 September 2015, 18:36 GMT
$ git tag --contains 49895bcc7e56
v4.2
v4.2-rc6
v4.2-rc7
v4.2-rc8
v4.2.1
v4.3-rc1
v4.3-rc2

$ git tag --contains 2d5b569b665e
v4.2
v4.2-rc4
v4.2-rc5
v4.2-rc6
v4.2-rc7
v4.2-rc8
v4.2.1
v4.3-rc1
v4.3-rc2

linux 4.2 does seem to have these commits. Since this bug is pretty severe, I thought an immediate patch would be welcomed because 4.2 is still in testing. A kernel panic every few minutes is pretty bad.

If nothing else, maybe this will influence a quicker move of 4.2 from testing to core.
Comment by Christian Hesse (eworm) - Saturday, 26 September 2015, 18:43 GMT
This is a duplicate of  FS#46002  (linux) and  FS#46444  (linux-lts).

Tobias refused to patch linux as version 4.2.x is in testing already.

Loading...