Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46333 - [midori] This package should depend of webkit2gtk and not webkitgtk

Attached to Project: Community Packages
Opened by num3r1c4bl3 (num3r1c4bl3) - Friday, 18 September 2015, 00:13 GMT
Last edited by Alexander F. Rødseth (xyproto) - Sunday, 01 November 2015, 18:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

midori should depend of webkit2gtk and not webkitgtk. The webkitgtk package (= WebKit1GTK+ branch) in unmaintained since 2014 (https://trac.webkit.org/wiki/WebKitGTK/WebKit2Roadmap) and offers a significantly outdated version with various instabilities (2.4.9). Webkit2GTK+ is considered the right dependency as of Midori 0.5.11 (http://www.twotoasts.de/index.php/2015/08/heads-or-tails/).
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Sunday, 01 November 2015, 18:47 GMT
Reason for closing:  No response
Comment by Alexander F. Rødseth (xyproto) - Monday, 21 September 2015, 08:17 GMT
Thanks for reporting! I was not aware of this.
Comment by Alexander F. Rødseth (xyproto) - Saturday, 24 October 2015, 15:23 GMT
When changing the dependency and make dependency to webkit2gtk (which is in version 4.0 in the official repos (/usr/lib/pkgconfig/webkit2gtk-4.0.pc)), it is not recognized by the build process.

After changing CMakeLists.txt to look for version 4.0 instead of 3.0 for webkit2gtk, javascriptcoregtk and webkit2gtk-web-extension, it accepts it, but then complains that webkitgtk-3.0 was not found:

-- checking for module 'gcr-3>=2.32'
-- found gcr-3, version 3.18.0
-- checking for modules 'gtk+-3.0>=3.10.0;webkitgtk-3.0>=1.8.1;javascriptcoregtk-4.0'
-- package 'webkitgtk-3.0>=1.8.1' not found
[...]
-- Configuring incomplete, errors occurred!

Have you tried building the latest version of midori with webkit2gtk 2.10.2? Are there any tricks that needs to be employed?
Comment by Alexander F. Rødseth (xyproto) - Sunday, 01 November 2015, 18:47 GMT
I read the post at twotoasts.de.

Midori compiles with the current webkitgtk package (3.0), but no webkit2gtk (4.0).

Closing this bug.

Please re-open if you think this is incorrect, and have indications that midori should be able to compile with webkit2gtk.

Loading...