Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46303 - [libreoffice-fresh] Writer formula editor freezing

Attached to Project: Arch Linux
Opened by Tomi Leppänen (Tomin) - Tuesday, 15 September 2015, 18:19 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 04 February 2016, 17:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Today I tried to do my homework on my laptop and I had to do some formulas. I used Libreoffice Writer (fresh version, 5.0.1-1) and always when I edit a formula it gets stuck into an infinite loop. One processor core is fully used and Writer is completely unresponsive. I can only kill it, which Gnome actually suggests after a while. It doesn't matter how I edit the formula but after a bit of editing it just freezes.

Additional info:
* package version(s)
libreoffice-fresh 5.0.1-1

Steps to reproduce:
I can't really say. Making a new file with a formula (I have multiple now) and working with them seems to trigger this. The freeze happens always when editing a formula, newer outside the editor.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 04 February 2016, 17:52 GMT
Reason for closing:  No response
Comment by Tomi Leppänen (Tomin) - Tuesday, 15 September 2015, 18:20 GMT
And I forgot the summary. Very nice. I don't know how to edit it. It could be something like "Writer formula editor freezing".
Comment by Andreas Radke (AndyRTR) - Wednesday, 16 September 2015, 18:37 GMT
Please check LibO-still. I guess this is some upstream code regression.

Maybe it's related to the gtk3 vlc. You may want to try gtk2 vlc or generic fallback vlc.
Comment by Tomi Leppänen (Tomin) - Wednesday, 30 September 2015, 16:33 GMT
I tried libreoffice-still. It worked just fine. No slow down or freeze.

I tried SAL_USE_VCLPLUGIN=gtk3 libreoffice and SAL_USE_VCLPLUGIN=gtk2 libreoffice and they both froze. When I used SAL_USE_VCLPLUGIN=gen libreoffice it didn't freeze but it was very slow. I noticed that in the formula I was editing adding some random text after word newline makes it slow or frozen.

I also tried to make a more generic example (to be shared) that would show the problem, but weirdly even if I just copy the formula I used to test this to another document, there is no problem. It works just fine. If I remove most of the text in the document I was editing, I can't make it to freeze.

What should be noted though is that with libreoffice-still that it doesn't slow down at all but with libreoffice-fresh it does slow down. I think there must be some loop that doesn't exist in the older version.
Comment by Andreas Radke (AndyRTR) - Monday, 04 January 2016, 18:38 GMT
Has this been solved with recent updates? gtk2 and kde4 vcl should work, also the generic vcl. gtk3 has been disabled for 5.0.x tree.

Loading...