Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46297 - [iputils] 'ping' utility does not work

Attached to Project: Arch Linux
Opened by Denis Seleznev (dseleznev89) - Tuesday, 15 September 2015, 02:33 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 15 March 2016, 07:33 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: ping utility from iputils package does not work:

ping: socket: Address family not supported by protocol (raw socket required by specified options).


Additional info:
* iputils-20150815.1b5d03a-2



Steps to reproduce:
try to ping any host
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 15 March 2016, 07:33 GMT
Reason for closing:  Fixed
Comment by guido (qqqqqqqqq9) - Tuesday, 15 September 2015, 10:16 GMT
Perhaps related: /usr/bin/ping6 is missing from testing/iputils
Comment by Jens Adam (byte) - Thursday, 17 September 2015, 05:39 GMT Comment by Inanc Gee (inanc) - Thursday, 17 September 2015, 09:02 GMT
ping6 and ping have been merged
use ping -4 <host>, that should work
Comment by guido (qqqqqqqqq9) - Thursday, 17 September 2015, 13:42 GMT
Yes, ping -4 works for me.
However some programs rely on ping being ping -4. For me, for instance, mythfrontend from aur/mythtv-git fails with iputils from testing:

2015-09-17 15:33:10.171227 I Loading de translation for module mythfrontend
2015-09-17 15:33:10.171450 I MythCoreContext::ConnectCommandSocket(): Connecting to backend server: localhost:6543 (try 1 of 1)
2015-09-17 15:33:10.171575 E MythCoreContext::GetBackendServerIP(): No address defined for host: localhost
2015-09-17 15:33:10.172063 E MythSocket(7f9be800eaf0:-1): Failed to connect to (127.0.0.1:6543) Verbindung verweigert
2015-09-17 15:33:10.172183 E Connection to master server timed out.
Either the server is down or the master server settings
in mythtv-settings does not contain the proper IP address


Is that a mythtv-bug?
Comment by John (gee) - Wednesday, 23 September 2015, 07:40 GMT
Similarly to guido, I get a lot of failures about ping from networkmanager in journalctl.
Should there be some changes in nm to accommodate?
Comment by Theodor van Nahl (tvn87) - Thursday, 24 September 2015, 00:02 GMT
Is it on purpose that ping breaks here the compatibility? The -4 parameter isn't even documented in the manpage.
Comment by Sebastiaan Lokhorst (lonaowna) - Thursday, 01 October 2015, 20:46 GMT
It still works fine here: if I don't specify anything, it seems to default to "-4".
Have you manually disabled IPv6 or something? Is your /etc/hosts correct?

Indeed the manpage seems outdated. It still refers to "ping6".
Kind of related: tpowa, you can remove the ping6 manpage symlink (ln -sf ping.8.gz ping6.8.gz) from the pkgbuild, since the command no longer exists.
Comment by Sebastiaan Lokhorst (lonaowna) - Thursday, 01 October 2015, 20:51 GMT Comment by John (gee) - Friday, 02 October 2015, 08:58 GMT
Sebastiaan: it does not here..
I am not sure what you mean by /etc/hosts correct so I cannot say, but I do have
alias net-pf-10 off
options ipv6 disable
and ipv6.disable=1 for the kernel.
Comment by Sebastiaan Lokhorst (lonaowna) - Friday, 02 October 2015, 09:31 GMT
That might be it. Is there a reason why you've disabled ipv6?
If you enable ipv6 again, is there any difference in the behaviour of ping?
Comment by John (gee) - Friday, 02 October 2015, 10:55 GMT
I will try.
I've disabled ipv6 because I do not use it (yet), I think I had a perf reason in mind when I did that but I am not sure anymore.
Comment by John (gee) - Friday, 02 October 2015, 11:02 GMT
Yup that worked!
Why does it work that way?
Comment by Sebastiaan Lokhorst (lonaowna) - Friday, 02 October 2015, 11:22 GMT
I'm not sure, I guess ping expects IPv6 to be enabled in the kernel. I don't think there really is a good reason to disable it at the kernel level anyway. Most network utilities should provide an option to disable IPv6. Disabling it in the kernel is overkill.
Comment by Theodor van Nahl (tvn87) - Saturday, 03 October 2015, 13:14 GMT
I had disabled IPv6, too. Had done it because of an router that spreaded wrong ipv6 addresses and disabling ipv6 in the kernel has been the fastest way I could think of. I agree with you, I should have done this in NetworkManager.
Comment by Sebastiaan Lokhorst (lonaowna) - Friday, 23 October 2015, 14:33 GMT
While I think IPv6 should not be disabled, it makes no sense that ping fails if it is. I've opened an upstream bug report: https://github.com/iputils/iputils/issues/32
Comment by Sebastiaan Lokhorst (lonaowna) - Sunday, 15 November 2015, 12:06 GMT
Upstream has fixed the issue![1]

[1] https://github.com/iputils/iputils/issues/32
Comment by Sebastiaan Lokhorst (lonaowna) - Tuesday, 05 January 2016, 11:33 GMT
Could the package in [testing] please be updated? Then we can finally close this issue. :)

Loading...