Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46295 - [mdadm] Failure to assemble IMSM array

Attached to Project: Arch Linux
Opened by Justin Capella (justincapella) - Monday, 14 September 2015, 17:39 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 20 September 2015, 03:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: Upgrading mdadm results in inability to assemble IMSM array (intel's fakeraid).


Additional info:
mdadm-3.3.4-1-x86_64
Downgrading to mdadm-3.3.2-2-x86_64 resolves issue.

Steps to reproduce:
mdadm -Avs
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 20 September 2015, 03:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Configuration issue
Comment by Mehmet Türk (mmturk) - Tuesday, 15 September 2015, 15:27 GMT
I have the same problem with intel rapid storage.
Comment by Justin Capella (justincapella) - Wednesday, 16 September 2015, 00:11 GMT
That confirms it, I am also using Intel's RapidStorage... any additional info I can provide please advise
Comment by Justin Capella (justincapella) - Wednesday, 16 September 2015, 05:35 GMT Comment by Justin Capella (justincapella) - Thursday, 17 September 2015, 21:00 GMT
I wrote to the mdadm mailing list, asking what to do if for instance the raid was created with a different motherboard, and the OROM settings had never been configured, but you had still been using the array prior to this commit. I received this helpful response from Artur Paszkiewicz:

You can use IMSM_NO_PLATFORM environment variable (see man mdadm), but if
your new motherboard also supports IMSM, then you can just enable it.
The raid will be detected normally and this should not cause data loss.

Loading...