Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46254 - [samba] Main process exited, code=dumped, status=6/ABRT

Attached to Project: Arch Linux
Opened by Jamp (jamp) - Friday, 11 September 2015, 08:18 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 11 September 2015, 16:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

smbd crashes at startup both with my customized smb.conf and with the default one.

After the upgrade to 4.3.0 I had a problem with the permissions with the /var/cache/samba/msg folder. Fixing permissions worked.
After the library upgrade I did this morning smbd keeps crashing.

the upgraded packages are

redis-3.0.4-2-x86_64.pkg.tar.xz
closure-compiler-20150901-1-any.pkg.tar.xz
blender-17:2.75.a-2-x86_64.pkg.tar.xz
perl-http-message-6.11-1-any.pkg.tar.xz
mariadb-10.0.21-2-x86_64.pkg.tar.xz
mariadb-clients-10.0.21-2-x86_64.pkg.tar.xz
libva-intel-driver-1.6.1-1-x86_64.pkg.tar.xz
libmariadbclient-10.0.21-2-x86_64.pkg.tar.xz
cups-filters-1.0.75-1-x86_64.pkg.tar.xz
libxi-1.7.5-1-x86_64.pkg.tar.xz
libva-1.6.1-1-x86_64.pkg.tar.xz
jemalloc-4.0.0-1-x86_64.pkg.tar.xz
libtasn1-4.6-1-x86_64.pkg.tar.xz
libgcrypt-1.6.4-1-x86_64.pkg.tar.xz
bash-4.3.042-1-x86_64.pkg.tar.xz


the crash log is

‚óŹ smbd.service - Samba SMB/CIFS server
Loaded: loaded (/usr/lib/systemd/system/smbd.service; enabled; vendor preset: disabled)
Active: failed (Result: core-dump) since Fri 2015-09-11 10:06:31 CEST; 13s ago
Process: 7054 ExecStart=/usr/bin/smbd -D (code=exited, status=0/SUCCESS)
Main PID: 7055 (code=dumped, signal=ABRT)
CGroup: /system.slice/smbd.service

Sep 11 10:06:31 hoothoot smbd[7055]: #6 /usr/bin/smbd(main+0x12eb) [0x55a068db94db]
Sep 11 10:06:31 hoothoot smbd[7055]: #7 /usr/lib/libc.so.6(__libc_start_main+0xf0) [0x7f969d91e610]
Sep 11 10:06:31 hoothoot smbd[7055]: #8 /usr/bin/smbd(_start+0x29) [0x55a068db9c19]
Sep 11 10:06:31 hoothoot smbd[7055]: [2015/09/11 10:06:31.733514, 0] ../source3/lib/dumpcore.c:318(dump_core)
Sep 11 10:06:31 hoothoot smbd[7055]: dumping core in /var/log/samba/cores/smbd
Sep 11 10:06:31 hoothoot smbd[7055]:
Sep 11 10:06:31 hoothoot systemd[1]: smbd.service: Main process exited, code=dumped, status=6/ABRT
Sep 11 10:06:31 hoothoot systemd[1]: smbd.service: Unit entered failed state.
Sep 11 10:06:31 hoothoot systemd[1]: smbd.service: Failed with result 'core-dump'.
Sep 11 10:06:31 hoothoot systemd-coredump[7063]: Process 7055 (smbd) of user 0 dumped core.




Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 11 September 2015, 16:46 GMT
Reason for closing:  Duplicate
Additional comments about closing:  #46240
Comment by Tomas M. (eldragon) - Friday, 11 September 2015, 12:19 GMT
just a me too. so that i get notified ;)

Comment by ealrann (ealrann) - Friday, 11 September 2015, 12:21 GMT
Same problem here after 4.3 update. Both smbd and nmdb services crash when started.

Loading...