AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
https://wiki.archlinux.org/title/Bug_reporting_guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://gitlab.archlinux.org/archlinux/aurweb/
Tasklist

FS#46228 - Unpolished dependecy resolution for PKGBUILDs

Attached to Project: AUR web interface
Opened by Gordian Edenhofer (Edenhofer) - Tuesday, 08 September 2015, 19:29 GMT
Last edited by Lukas Fleischer (lfleischer) - Wednesday, 09 September 2015, 07:31 GMT
Task Type Feature Request
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.0-rc6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The dependency resolution of PKGBUILDs which depend on parts of a project which may be provided by multiple packages are handled differently at the official package browser than it is done in the AUR web interface.
For example the package gnome-session [1] depends on libgl, however libgl is provided by both nvidia-libgl as well as by mesa-libgl. On the package browser at the archlinux.org page all of those alternatives are shown in brackets. However the AUR web interface is unable to resolve those connections (see [2]).

[1] https://www.archlinux.org/packages/extra/x86_64/gnome-session/
[2] https://aur.archlinux.org/packages/zoom/
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Wednesday, 09 September 2015, 07:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#14125 .

Loading...