Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46201 - [gnome-terminal] unexplained low ulimit

Attached to Project: Arch Linux
Opened by ikohvei (ikohvei) - Friday, 04 September 2015, 19:12 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 14 November 2015, 15:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Using the ulimit -Hn or ulimit -Sn commands, from within gnome-terminal the result is always 256. In other terminals (xterm and urxvt tested) the result is the normal system limit of 4096. Launching xterm from within a gnome-terminal ends up with xterm inheriting the the 256 low limit. Launching gnome-terminal from within a xterm ends up with gnome-terminal not inherenting the higher limit, and instead ending up with the low 256 limit again.

This low 256 ulimit is blocking some apps from being able to be launched from within gnome-terminal.

Additional info:
gnome-terminal 3.16.2-1

This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 14 November 2015, 15:53 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#46374
Comment by ikohvei (ikohvei) - Friday, 04 September 2015, 20:47 GMT
Another detail. Attempting to modify the limit fails.

$ ulimit -n 4096
bash: ulimit: open files: cannot modify limit: Operation not permitted
Comment by ikohvei (ikohvei) - Friday, 04 September 2015, 21:20 GMT
The ulimit command is not even working in gnome-terminal. It throws an error.

bash: ulimit: open files: cannot modify limit: Operation not permitted

This is not caused by a limit higher then the global setting. Attempting to set above the global setting (from a different terminal app) returns this error.

bash: ulimit: open files: cannot modify limit: Invalid argument
Comment by Jan Alexander Steffens (heftig) - Saturday, 05 September 2015, 10:22 GMT
Fine for me using GNOME (soft 1024, hard 4096).

The FD limit is inherited from dbus-daemon. Check what launches dbus-daemon for your session.
Comment by ikohvei (ikohvei) - Sunday, 06 September 2015, 00:47 GMT
I am reading that dbus-daemon is a dependency of systemd. ps aux shows that it is running.

/usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
as user dbus

Im using openbox as a WM.
Comment by Jan Alexander Steffens (heftig) - Sunday, 06 September 2015, 01:11 GMT
Wrong daemon. Look for one running as your user.
Comment by ikohvei (ikohvei) - Wednesday, 23 September 2015, 03:22 GMT
After latest system upgrade (with new systemd dbus), gnome-terminal stopped working completely. Now I get this error.

$ gnome-terminal
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1
Comment by ikohvei (ikohvei) - Tuesday, 29 September 2015, 18:01 GMT

Loading...