Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46176 - [minetest] or [irrlicht] Incompatibility between minetest 0.4.12 and irrlicht 1.8.2-1

Attached to Project: Community Packages
Opened by Jonathan Duck (duckbrain) - Wednesday, 02 September 2015, 15:14 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Saturday, 05 September 2015, 10:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
minetest 0.4.12 and irrlicht 1.8.2-1 cause minetest to fail to launch (output attached). I rolled back to irrlicht 1.8.1-2 from my cache and things work perfectly. I have not tried with the newest minetest 0.4.13 because the package has not yet been updated, but their change log does not indicate fixing any bugs related to irrlicht except for logging and building. I don't have any other software that uses irrlicht to test if this is a irrlicht issue or minetest issue.

Additional info:
* Minetest changelog http://dev.minetest.net/Changelog#0.4.12_.E2.86.92_0.4.13



Steps to reproduce:
1. Install minetest and ensure all packages are updated
2. Run minetest
   debug (19.5 KiB)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Saturday, 05 September 2015, 10:03 GMT
Reason for closing:  Fixed
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 03 September 2015, 17:47 GMT
This is an issue in Irrlicht, I'm pretty sure. Nothing to do with minetest.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 03 September 2015, 18:15 GMT
Please test the new irrlicht build rel -2.
Comment by Milan (Technics) - Friday, 04 September 2015, 18:01 GMT
Im not able to start Minetest anymore... .
For the people i know, the -2 have fixed the issues - i got a new one.
Im not sure if i did something Irrlicht doesnt like...i doesnt know to help me anymore:

2015-09-04 19:51:06: ACTION[main]: Irrlicht: Warning: The library version of the Irrlicht Engine (1.8.2) does not match the version the application was compiled with (0u_`). This may cause problems.
2015-09-04 19:51:06: ERROR[main]: Irrlicht: Fatal error, could not get visual.
2015-09-04 19:51:06: ERROR[main]: Could not initialize game engine.

I think it have something todo with my prop. nvidia card?
The Issue is the same with 1.8.1...

Edit: SuperTuxKart works fine - but i dont know if they bring their own Irrlicht with the game...
Comment by Jonathan Duck (duckbrain) - Saturday, 05 September 2015, 02:59 GMT
The -2 build fixed it. Thank you.
Comment by Jonathan Duck (duckbrain) - Saturday, 05 September 2015, 06:50 GMT
The -2 build fixed it. Thank you.

Loading...