Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46142 - [qt5] Not drawed tooltips, popups and applications contents

Attached to Project: Arch Linux
Opened by webnull (webnull) - Saturday, 29 August 2015, 13:14 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 29 August 2015, 14:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Tooltips, windows and popups are not drawed properly.
This affects only Qt based applications. GTK applications are working as expected.

It affects dolphin, yakuake, kmix, kde lockscreen (it does not display text, the login box stays, and the text input will be drawed only when I click it).

Also KDE notifications regarding soundcard are broken, sometimes wicd-qt, generally I think that all Qt applets are not painting correctly the interface.

Cannot use my computer! :(

Additional info:
* package version(s)
qt5-base 5.5.0-2
qt5-connectivity 5.5.0-2
qt5-declarative 5.5.0-2
qt5-graphicaleffects 5.5.0-2
qt5-imageformats 5.5.0-2
qt5-location 5.5.0-2
qt5-multimedia 5.5.0-2
qt5-quick1 5.5.0-2
qt5-quickcontrols 5.5.0-2
qt5-script 5.5.0-2
qt5-sensors 5.5.0-2
qt5-serialport 5.5.0-2
qt5-svg 5.5.0-2
qt5-tools 5.5.0-2
qt5-translations 5.5.0-2
qt5-webchannel 5.5.0-2
qt5-webkit 5.5.0-2
qt5-x11extras 5.5.0-2
qt5-xmlpatterns 5.5.0-2
* config and/or log files etc.
I don't know what to share with you.
When I'm launching the dolphin, it's displaying a notice in console after redrawing the content:
QXcbShmImage: shmget() failed (28) for size 2663496 (1254x531)

Maybe it could be somehow related.


Steps to reproduce:
- Just use your computer, it gets worst mostly time when getting out of suspend, but it's also broken when not suspending. After suspend there could be more elements badly painted on the screen.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 29 August 2015, 14:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#45824 
Comment by webnull (webnull) - Saturday, 29 August 2015, 13:16 GMT
What I forgot to mention - I have a second user in a system, it have pure default configuration of KDE. The problem is here as well. It also does not depends on KWin effects. Even if I turn off KWin effects it looks worst.

It's all after system update. Before system worked. First time graphics glithes appeared was about a month ago.

$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]
Comment by Antonio Rojas (arojas) - Saturday, 29 August 2015, 13:26 GMT
Are you running a Java application with openjdk7?
Comment by webnull (webnull) - Saturday, 29 August 2015, 14:47 GMT
Yes, what's wrong? Is it connected directly to the problem?

$ pacman -Q |grep jdk
jdk7-openjdk 7.u85_2.6.1-1
jre7-openjdk 7.u85_2.6.1-1
jre7-openjdk-headless 7.u85_2.6.1-1
Comment by Antonio Rojas (arojas) - Saturday, 29 August 2015, 14:50 GMT
Yes, it's the cause of this problem

Loading...