Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46124 - [networkmanager-openvpn] missing user (and maybe group)

Attached to Project: Arch Linux
Opened by Mauro Santos (R00KIE) - Thursday, 27 August 2015, 21:51 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 28 August 2015, 10:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
After the update to networkmanager 1.0.6-1 and networkmanager-openvpn 1.0.6-1, openvpn vpn connections do not work.

The output of journalctl says:
Ago 27 22:34:33 arch64 NetworkManager[570]: <info> Starting VPN service 'openvpn'...
Ago 27 22:34:33 arch64 NetworkManager[570]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 1323
Ago 27 22:34:33 arch64 NetworkManager[570]: <info> VPN service 'openvpn' appeared; activating connections
Ago 27 22:34:33 arch64 NetworkManager[570]: <info> VPN plugin state changed: starting (3)
Ago 27 22:34:33 arch64 NetworkManager[570]: <info> VPN connection 'My VPN' (ConnectInteractive) reply received.
Ago 27 22:34:33 arch64 NetworkManager[570]: <warn> VPN connection 'My VPN' failed to connect interactively: 'User 'nm-openvpn' not found, check NM_OPENVPN_USER.'.
Ago 27 22:34:33 arch64 NetworkManager[570]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
Ago 27 22:34:53 arch64 NetworkManager[570]: <info> VPN service 'openvpn' disappeared

This seems to point either to a missing username that should be created when installing networkmanager-openvpn or a missing environment variable defined somewhere (maybe /etc/profile.d ?, I have never tested if stuff there affects the environment of services). It is probable that a group is also missing, but that may be masked because the connection is aborted on the first error.

Searching on google for NM_OPENVPN_USER returns this [1] and this forum thread [2].

Additional info:
networkmanager 1.0.6-1
networkmanager-openvpn 1.0.6-1


Steps to reproduce:
Update system and make sure networkmanager 1.0.6-1 and networkmanager-openvpn 1.0.6-1 are installed.
Try to connect to any openvpn VPN .

[1] https://mail.gnome.org/archives/commits-list/2015-June/msg00321.html
[2] https://bbs.archlinux.org/viewtopic.php?id=201647
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 28 August 2015, 10:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  networkmanager-openvpn 1.0.6-2
Comment by Daniel Kozák (kozzi) - Thursday, 27 August 2015, 21:54 GMT Comment by AnAkkk (AnAkkk) - Thursday, 27 August 2015, 23:26 GMT
This fixes the issue for me:

groupadd -r nm-openvpn
useradd -r -g nm-openvpn -d / -s /sbin/nologin -c "Default user for running openvpn spawned by NetworkManager" nm-openvpn
Comment by Mauro Santos (R00KIE) - Thursday, 27 August 2015, 23:41 GMT
@AnAkkk
That (or similar) needs to be done when the package is installed.

On the other hand I'm not sure why upstream decided to go their own way with user:group when they could have used nobody:nobody which is what is used on the examples provided with openvpn.
Comment by Daniel Kozák (kozzi) - Thursday, 27 August 2015, 23:50 GMT
What I still do not understand is how this package can end up in stable extra without going through testing?
Comment by Sebastian Jug (jugs) - Friday, 28 August 2015, 00:35 GMT
This is going to break a LOT of installs. What happened to testing?
Comment by naghmash (naghmash) - Friday, 28 August 2015, 05:50 GMT
It Worked. Thanks

Loading...