FS#46092 - [linux] 4.1.6-1 Lock up on 2x x86_64 Archlinux installations

Attached to Project: Arch Linux
Opened by cirrus (cirrus) - Monday, 24 August 2015, 10:30 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 29 June 2016, 19:11 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Additional info: Description: Today i updated 2 archlinux x86_64 installs, after reboot both systems have no network and no mouse / keyboard input, this happened on two seperate installs, downgraded both installs to 4.1.5-1 then both worked as normal. [ Mobo: ASUSTeK model: P6T SE v: Rev 1] : [GPU: AMD/ATI] RV770 [Radeon HD 4870]

* package version(s) linux 4.1.6-1
* config and/or log files etc. sorry im am newb , i didnt have the wherewithall to copy/paste logs whilst in arch-chroot :/

Steps to reproduce: Uprade to 4.1.6-1, Downgrade to 4.1.5-1
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 29 June 2016, 19:11 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Monday, 24 August 2015, 13:52 GMT
Without some kind of log, this report is pretty useless. Really, it's useless to report kernel bugs here, anyway.
Comment by cirrus (cirrus) - Monday, 24 August 2015, 16:52 GMT
Duly noted @Scimmia, cheers.
Comment by patrick (potomac) - Monday, 24 August 2015, 17:06 GMT
anyway you need to do more investigations in order to find what went wrong in kernel 4.1.6,

the best method is to do a "git bisect", in order to find the faulty git commit :


using ccache can speed up the compilation time ( this feature can be enabled in makepkg.conf file ) :


you can compile each kernel version with "makepkg" ( with prefix name : linux_custom, you can set it in the pkgbuild file ),

when you will find the faulty commit you have to create a bugreport on the kernel's bugzilla in order to warn the kernel developers
Comment by cirrus (cirrus) - Monday, 24 August 2015, 18:45 GMT
Thanks for the info patrick
Comment by cirrus (cirrus) - Tuesday, 25 August 2015, 19:05 GMT
seems it is HW specific as that kernel installed fine on intel based laptop.
Comment by Michael Schaller (schallmi) - Thursday, 03 September 2015, 07:38 GMT
I got the same behaviour on my X201 ThinkPad. After booting there were only a few kernel-mods loaded. There were no errors in the log-files (journalctl -b). Downgrade to 4.1.5-1 fixed it.
Comment by Michael Schaller (schallmi) - Thursday, 03 September 2015, 18:25 GMT
Damn!! While trying to configure grub for the linux-git kernel from AUR, i recognized that my boot-partition was not mounted. That explains why my mods were not loaded on boot after the 'pacman -Syu'. Old kernel with new mods doesn't work :)

I installed arch via the evo-boot image. Either I missed the part to configure the fstab or the script does'nt add the boot-partition to the fstab.

If anyone else got this error, please check if your boot-partition was mounted well during kernel update. cirrus please check your boot-partiton (execute 'mount | grep /boot' in a shell. if there is no output you have the same problem like me)
Comment by Samantha McVey (samcv) - Friday, 10 June 2016, 00:31 GMT
Can any of the people with this issue report if it is no longer an issue with the most recent Arch Linux kernel? Please let me know. Thank you.
Comment by Samantha McVey (samcv) - Saturday, 25 June 2016, 22:25 GMT
Michael, or cirrus, are you still seeing this? Let me know if this has been fixed so it can be closed if required.
Comment by cirrus (cirrus) - Wednesday, 29 June 2016, 18:21 GMT
Samantha, I'm no longer using 4.1.6-1 and i've not seen this behaviour since 4.1.6-1 got updated.