Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46081 - [geeqie] Float window uses image window dimensions

Attached to Project: Arch Linux
Opened by Laurent Durand (ignace72) - Sunday, 23 August 2015, 15:33 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 20 July 2019, 17:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After updating in version 1.2.1, it seems the saved state for the files list window is
the same of the image window. Move or resize any of them, and in next
use they both will appear as the image one was when closing. Geeqie
worked fine in version 1.1.

Additional info:
* package versionĀ : geeqie 1.2.1-1
* config file geeqierc.xml

...
main_window.x = "161"
main_window.y = "71"
main_window.w = "1310"
main_window.h = "851"
main_window.maximized = "false"
main_window.hdivider_pos = "404"
main_window.vdivider_pos = "200"

float_window.x = "71"
float_window.y = "71"
float_window.w = "1310"
float_window.h = "851"
float_window.vdivider_pos = "415"
...

Steps to reproduce:

1- With Geeqie you must click on the "List of files floating" button.
2- We must put the image window and the file list window to different positions and different sizes such as a window on the right screen and the other window on the left screen.
3- We must close the software.
4- It should reopen Geeqie.
5- Surprise, the file list window is exactly on the image window and both windows are the same size.

Thanks you.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 20 July 2019, 17:10 GMT
Reason for closing:  Fixed
Comment by Laurent Durand (ignace72) - Sunday, 23 August 2015, 15:42 GMT
I said that it is on x86_64.

For now, I filled the coordinates by hand like this (and I put the configuration file read-only before closing the software):
...
main_window.x = "0"
main_window.y = "0"
main_window.w = "1920"
main_window.h = "851"
main_window.maximized = "true"
main_window.hdivider_pos = "404"
main_window.vdivider_pos = "200"

float_window.x = "1920"
float_window.y = "0"
float_window.w = "1920"
float_window.h = "1054"
float_window.vdivider_pos = "415"
...
Comment by Jelle van der Waa (jelly) - Saturday, 05 January 2019, 11:40 GMT
Ping? Latest version in the repo is no 1.4-3
Comment by Stefan Schick (pommes_) - Saturday, 20 July 2019, 11:45 GMT
Tested with current version from arch extra repository (geeqie-1.4-4). Issue does not appear, I guess it was fixed upstream.
Can anyone confirm?
Comment by Laurent Durand (ignace72) - Saturday, 20 July 2019, 16:04 GMT
The problem is solved.
Thank you all.

Loading...