Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46068 - frequency file /var/lib/ntp/ntp.drift.TEMP: Permission denied

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Saturday, 22 August 2015, 11:00 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 26 August 2015, 21:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There seems some permissions wrong.

frequency file /var/lib/ntp/ntp.drift.TEMP: Permission denied

Additional info:
* package version(s)
latest
* config and/or log files etc.
Default config

Steps to reproduce:
Start ntpd.service
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 26 August 2015, 21:43 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Saturday, 22 August 2015, 14:53 GMT
That dir is owned by the ntp user, so it should work fine. Could you give more details?
Comment by Doug Newgard (Scimmia) - Wednesday, 26 August 2015, 13:36 GMT
Ping? Are your permissions different than those of the package?
Comment by Ruben Kelevra (RubenKelevra) - Wednesday, 26 August 2015, 18:58 GMT
Well sorry, read the mail but forgot to response.

The permissions-issue was created by a restore from a backup. It was root:root for the folder. I fixed it and it worked. So this ticket can be closed as invalid.

But it's might be a good idea to set the folder-permissions for this folder explicit, with an install script? :)


Best regards


Ruben
Comment by Daniel Micay (thestinger) - Wednesday, 26 August 2015, 19:06 GMT
It has been ntp:ntp for a really long time now. It doesn't need an install file hack.

Loading...