Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46036 - [polkit] pkexec does not work

Attached to Project: Arch Linux
Opened by Jean-Baptiste Lamy (jiba) - Thursday, 20 August 2015, 12:34 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 20 August 2015, 17:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

pkexec command is not working, and always

Additional info:
* package version(s) : polkit 0.113-2-x86_64
* config : no specific configuration ; pkexec was working before updating my system.

Steps to reproduce:

run (as normal user) :

pkexec ls

If a wrong password is entered, I get the "wrong password" dialog box after one second, as expected.
But if the right root password is entered, I get the same "wrong password" dialog box, immediately (without one-second delay).
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 20 August 2015, 17:33 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Thursday, 20 August 2015, 12:45 GMT
did you reload the polkit daemon after upgrading?
Comment by Jean-Baptiste Lamy (jiba) - Thursday, 20 August 2015, 17:33 GMT
No ; I've just restarted it with systemctl and it now works well.

Thank you !

Loading...