Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#46027 - [firefox] indexeddb doesn't work anymore

Attached to Project: Arch Linux
Opened by Eric Le Lay (elelay) - Wednesday, 19 August 2015, 19:52 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 23 September 2015, 16:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I go to the home page, I get an UnknownError in the javascript console at aboutHome.js:228, which reads
let openRequest =, {version: DATABASE_VERSION,
A pouchdb application I'm developing gets the same "UnknownError" when starting.
I've tried the same thing in a fresh profile but still get the error.
Is it the same for everybody or just me?

Additional info:
* package version: 40.0.2-1
* x86_64,

Steps to reproduce:
- open a new tab in firefox
- show the welcome page (home icon right to the search field)
- open the javascript console (Ctrl+Shift+I)
- I see a single error: "UnknownError"
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 23 September 2015, 16:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears to be fixed in Firefox 41.
Comment by Doug Newgard (Scimmia) - Wednesday, 19 August 2015, 23:28 GMT
No problem here
Comment by Evangelos Foutras (foutrelis) - Thursday, 20 August 2015, 00:41 GMT Comment by Eric Le Lay (elelay) - Thursday, 20 August 2015, 07:12 GMT
Not 1165119: I don't have any morgue directory.
Maybe 1143003: a indexeddb+++fx-devtools directory is created in my storage/permanent dir.

What's strange is that I get the error on a fresh profile so everybody should also see it?!

Here is my fresh profile's contents. The storage/permanent/xxx dirs are created on startup automatically.
├── SiteSecurityServiceState.txt
├── addons.json
├── blocklist.xml
├── bookmarkbackups
├── cert8.db
├── compatibility.ini
├── content-prefs.sqlite
├── cookies.sqlite
├── datareporting
│   └── state.json
├── extensions.ini
├── extensions.json
├── gmp
├── gmp-gmpopenh264
│   └── 1.4
│   ├──
│   └──
├── healthreport
│   └── state.json
├── healthreport.sqlite
├── key3.db
├── mimeTypes.rdf
├── permissions.sqlite
├── places.sqlite
├── places.sqlite-shm
├── places.sqlite-wal
├── pluginreg.dat
├── prefs.js
├── revocations.txt
├── search-metadata.json
├── search.json
├── secmod.db
├── sessionCheckpoints.json
├── sessionstore-backups
│   ├── previous.js
│   ├── upgrade.js-20150807021757
│   └── upgrade.js-20150814092310
├── sessionstore.js
├── storage
│   └── permanent
│   ├── chrome
│   │   └── idb
│   │   └── 2918063365piupsah.sqlite
│   ├── indexeddb+++fx-devtools
│   │   └── idb
│   │   └── 478967115deegvatroootlss--cans.sqlite
│   └── moz-safe-about+home
│   └── idb
│   └── 818200132aebmoouht.sqlite
├── times.json
├── webapps
│   └── webapps.json
├── webappsstore.sqlite
└── xulstore.json

I've rollbacked to firefox-39.0.3-1-x86_64 and I don't get the error, on both profiles.
Since other Arch users don't see it, I guess I'll have to move it upstream...
Comment by patrick (potomac) - Thursday, 20 August 2015, 13:46 GMT
no problem with my configuration ( x86_64 version of firefox )

something is probably different in your configuration, check if you have really tested with a new firefox profile ( run "firefox -p" ),

and check if you don't have hardware problems ( check your ram modules with memtest, your hardisk with a tool like smartmontools ),

you can also test with the official firefox linux binary from the official site, or rebuild the firefox package ( with "makepkg" ) to see if it can solve the problem
Comment by Eric Le Lay (elelay) - Thursday, 20 August 2015, 21:00 GMT
It seems to be related to the free disk space.
When a profile is on a disk with 300-4OOMB free I get the error.
When I move it to someplace else where there are at least 6GB free, no error.

Thanks for your help.
Comment by Eric Le Lay (elelay) - Sunday, 23 August 2015, 09:33 GMT