Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#4601 - udev >=091-3 no longer loads the evdev kernel module

Attached to Project: Arch Linux
Opened by Tom Killian (tomk) - Monday, 08 May 2006, 21:33 GMT
Last edited by Judd Vinet (judd) - Tuesday, 25 July 2006, 22:15 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

udev>=091-3 does not automatically load the evdev kernel module, which causes synaptics and other similar drivers to fail, preventing X from starting. There are two workarounds - downgrade to 091-2, or load evdev another way - either manually or in rc.conf.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 05 November 2006, 07:38 GMT
Reason for closing:  Fixed
Comment by Greg Meyer (oggb4mp3) - Tuesday, 09 May 2006, 00:16 GMT
I was about to post this myself, so I can confirm the behavior.

X does not start on my laptop after upgrading to 091-3, and 091-4 does not fix it.
Comment by Judd Vinet (judd) - Thursday, 22 June 2006, 17:35 GMT
Re-opened by Greg Meyer:

091-5 still does not load evdev for me. Is a kernel newer than 2.6.15.4 required for this?
Comment by Tobias Powalowski (tpowa) - Thursday, 06 July 2006, 13:38 GMT
is this fixed in udev 094?
Comment by Jan de Groot (JGC) - Saturday, 08 July 2006, 18:45 GMT
Loads fine here, I don't have it specified anywhere and I also don't use it, but it gets loaded anyways. Could be my midi port of the SB Live that triggers the loading of this module.
Comment by Greg Meyer (oggb4mp3) - Sunday, 09 July 2006, 01:34 GMT
It works fine here too and has for some time, sorry, I should have commented sooner
Comment by Judd Vinet (judd) - Tuesday, 25 July 2006, 22:15 GMT
Re-opened by Tom Killian:

Sorry I'm late with this. evdev still does not autoload for me. I now have udev 095-1 and kernel26 2.6.17.4-2 installed. The device is a Synaptics touch pad, on a Dell Inspiron 5000.
Comment by Tobias Powalowski (tpowa) - Wednesday, 26 July 2006, 06:11 GMT
update to the latest version, remove udev.rules that you get the latest rules file too.
and try again.
Comment by Tom Killian (tomk) - Wednesday, 26 July 2006, 08:12 GMT
Now running udev 096-1 and kernel26 2.6.17.6-1, but evdev is still not autoloaded. I diffed the udev.rules file that I removed and the one that was just reinstalled, and they're the same.
Comment by Tobias Powalowski (tpowa) - Wednesday, 26 July 2006, 08:19 GMT
# EVDEV
ACTION=="add", SUBSYSTEM=="input", RUN+="/lib/udev/load-modules.sh evdev"
this is the rule, and it should be ever loaded if you have the input subsystem
Comment by Tom Killian (tomk) - Wednesday, 26 July 2006, 09:15 GMT
Fair enough. If there's nothing else to try, and if it's just me at this stage, it's probably another symptom of laptop old age. I don't mind loading it from rc.conf, so perhaps it would be best to put it down to experience, and move on. I only asked for it to be reopened in case it would be of any benefit to Arch or to other users.
Comment by Tobias Powalowski (tpowa) - Wednesday, 26 July 2006, 09:18 GMT
i don't know how to solve this issue, if you have an idea how to get udev to load this module then just tell me :)
on my 6 pcs it loads fine
Comment by Tobias Powalowski (tpowa) - Wednesday, 20 September 2006, 16:11 GMT
is this still valid with udev 100?
Comment by Tom Killian (tomk) - Wednesday, 20 September 2006, 21:49 GMT
Yeah, it is. I've just booted into the 2.6.18 kernel from testing with udev 100 installed, and evdev did not load.
Comment by Greg Meyer (oggb4mp3) - Saturday, 30 September 2006, 18:13 GMT
It works here with 2.6.18 and udev 100.
Comment by Greg Meyer (oggb4mp3) - Saturday, 30 September 2006, 18:13 GMT
Actually, I just booted into my old 2.6.15 custom kernel and evdev did not load, but it does with kernel 2.6.18.
Comment by Jan de Groot (JGC) - Saturday, 30 September 2006, 20:27 GMT
udev requires a quite recent kernel to operate correctly. This is due to many changes in sysfs in the latest kernels, which were not present in the 2.6.15 kernels.

Loading...