Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45972 - [glibc] 'LC_ALL=foo locale' prints all values apart from LANG as 'foo'.

Attached to Project: Arch Linux
Opened by Karol Błażewicz (karol) - Wednesday, 12 August 2015, 21:14 GMT
Last edited by Allan McRae (Allan) - Thursday, 13 August 2015, 10:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

$ LC_ALL=foo locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_XX.UTF-8@POSIX
LC_CTYPE="foo"
LC_NUMERIC="foo"
LC_TIME="foo"
LC_COLLATE="foo"
LC_MONETARY="foo"
LC_MESSAGES="foo"
LC_PAPER="foo"
LC_NAME="foo"
LC_ADDRESS="foo"
LC_TELEPHONE="foo"
LC_MEASUREMENT="foo"
LC_IDENTIFICATION="foo"
LC_ALL=foo

$ locale
LANG=en_XX.UTF-8@POSIX
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="en_XX.UTF-8@POSIX"
LC_TIME="en_XX.UTF-8@POSIX"
LC_COLLATE="en_XX.UTF-8@POSIX"
LC_MONETARY="en_XX.UTF-8@POSIX"
LC_MESSAGES="en_XX.UTF-8@POSIX"
LC_PAPER="en_XX.UTF-8@POSIX"
LC_NAME="en_XX.UTF-8@POSIX"
LC_ADDRESS="en_XX.UTF-8@POSIX"
LC_TELEPHONE="en_XX.UTF-8@POSIX"
LC_MEASUREMENT="en_XX.UTF-8@POSIX"
LC_IDENTIFICATION="en_XX.UTF-8@POSIX"
LC_ALL=

2.21-4 seems to be broken too: https://bbs.archlinux.org/viewtopic.php?pid=1552712#p1552712
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 13 August 2015, 10:14 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Thursday, 13 August 2015, 03:00 GMT
Working completely as expected.

Loading...