Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45956 - [octave] optdepends description for qscintilla outdated?

Attached to Project: Arch Linux
Opened by Lex Black (TrialnError) - Tuesday, 11 August 2015, 15:35 GMT
Last edited by Ronald van Haren (pressh) - Tuesday, 08 September 2015, 09:12 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Shouldn't the description for qscintilla be changed?
Since 4.0 the GUI isn't experimental anymore. In fact it's the default now if octave get's called.
If one want to use the cli versions he needs to use octave-cli or octave with the start-up options --no-gui or --no-gui-libs
This task depends upon

Closed by  Ronald van Haren (pressh)
Tuesday, 08 September 2015, 09:12 GMT
Reason for closing:  Implemented
Additional comments about closing:  4.0.0-2
Comment by Lex Black (TrialnError) - Monday, 17 August 2015, 14:49 GMT
Additionally the deps should be checked too.

Quote from the changelog:
"Octave now uses OpenGL graphics with Qt widgets by default. If OpenGL
libraries are not available when Octave is built, gnuplot is used.
You may choose to use the fltk or gnuplot toolkit for graphics by
executing the command

graphics_toolkit ("fltk")
OR
graphics_toolkit ("gnuplot")

Adding such a command to your ~/.octaverc file will set the default
for each session."

Which leaves the impression, that fltk could be an optdepend now.
Didn't check on that yet, but will probably later
Comment by Clemens Buchacher (drizzd) - Wednesday, 19 August 2015, 20:10 GMT
Since we use octave to build octave-forge packages, they also cannot build without qscintilla. We could work around it by using octave-cli instead of octave in the PKGBUILDs and .install's for the octave-forge packages, but that would be a lot of effort and it would not fix the root cause of the problem.
Comment by Lex Black (TrialnError) - Thursday, 20 August 2015, 14:44 GMT
Hmm.. Root cause. Sounds you favor to move qscintilla from optdepends to depends?
Personally I wouldn't like such a move.

And changing the PKGBUILD and install files would be one-timer and could be done with a script (sed, add+commit, push). If the packages will work with no problems even if qscintilla is used. Or is there something else problematic?
Comment by Ronald van Haren (pressh) - Thursday, 20 August 2015, 14:59 GMT
I guess I'll have to move qscintilla to depends as the gui is now the upstream default. I suppose it's confusing when /usr/bin/octave throws an error and the desktop file provided doesn't work by default as it uses the now default gui version.

As for fltk... octave seems to work without fltk installed and uses gnuplot just fine, but it throws an error in the main screen. Although this seems harmless, I'm not sure we would want an error to appear just after the application is started.
Comment by Lex Black (TrialnError) - Friday, 21 August 2015, 11:43 GMT
Valid point in case of upstream default. But shoving gui-components into optdeps, even if .desktop files are available, is done for some packages (ok, those already causes such bugreports, like ".desktop file isn't working --> check optdepends", "x needs y for the gui --> check optdepends").

And regarding fltk. No, such a startup error-message isn't really encouraging, even it is working fine. Kinda reminds of the matplotlib dilemma (choose your backend freely.. well, ok not so free, as my default I set while building is needed)
Comment by Matthew Carr (tac-shell) - Saturday, 05 September 2015, 14:32 GMT
I support moving qscintilla to depends. The GUI can't reasonably be considered an optional component when the upstream dev has it enabled by default and the build in the package respects this configuration.
Comment by Clemens Buchacher (drizzd) - Sunday, 06 September 2015, 09:02 GMT
Ronald, can you please move qscintilla from optdepends to depends?

Loading...