Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45955 - [libcanberra-pulse] Chromium hangs on "save as"

Attached to Project: Arch Linux
Opened by Alexandre Bique (babali) - Tuesday, 11 August 2015, 13:22 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 07 April 2022, 17:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I reported the bug in first place here:

https://code.google.com/p/chromium/issues/detail?id=517952

But it seems that it comes from libcanberra... what do you think?

Thank you,
Alex
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 07 April 2022, 17:50 GMT
Reason for closing:  No response
Comment by Doug Newgard (Scimmia) - Tuesday, 11 August 2015, 14:16 GMT
So you're not using pulse, do you have libcanberra-pulse installed?
Comment by Alexandre Bique (babali) - Tuesday, 11 August 2015, 14:18 GMT
I have it yes, now you say it I can remove it! :-)

Still there is a bug here, maybe in libcanberra-pulse.
Comment by Doug Newgard (Scimmia) - Tuesday, 11 August 2015, 14:23 GMT
If removing it fixes it, I wonder if libcanberra-pulse needs to depend on pulseaudio rather than just libpulse.
Comment by Alexandre Bique (babali) - Tuesday, 11 August 2015, 14:29 GMT
I can't say if it fixes it as it seems that there is a race condition with their code.
Having libcanbera-pulse without pulse audio seems useless right?
Comment by mattia (nTia89) - Saturday, 26 February 2022, 14:55 GMT
I cannot reproduce the issue. Is it still valid?
Comment by Guoyi (malacology) - Thursday, 07 April 2022, 14:59 GMT
I also have this issue
Comment by Guoyi (malacology) - Thursday, 07 April 2022, 15:15 GMT
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[85486:85486:0407/161434.132588:ERROR:sandbox_linux.cc(377)] InitializeSandbox() called with multiple threads in process gpu-process.
[85454:85454:0407/161434.757121:ERROR:interface_endpoint_client.cc(659)] Message 0 rejected by interface blink.mojom.WidgetHost
[85454:85454:0407/161435.972225:ERROR:object_proxy.cc(623)] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[85454:85454:0407/161435.972970:ERROR:object_proxy.cc(623)] Failed to call method: org.gnome.ScreenSaver.GetActive: object_path= /: org.freedesktop.DBus.Error.UnknownMethod: 对象在路径“/”处不存在
[85486:85486:0407/161439.036750:ERROR:shared_image_manager.cc(227)] SharedImageManager::ProduceSkia: Trying to Produce a Skia representation from a non-existent mailbox.
[85486:85486:0407/161439.037413:ERROR:shared_image_manager.cc(227)] SharedImageManager::ProduceSkia: Trying to Produce a Skia representation from a non-existent mailbox.
[85486:85486:0407/161439.038313:ERROR:shared_image_manager.cc(227)] SharedImageManager::ProduceSkia: Trying to Produce a Skia representation from a non-existent mailbox.
[85486:85486:0407/161439.039201:ERROR:shared_image_manager.cc(227)] SharedImageManager::ProduceSkia: Trying to Produce a Skia representation from a non-existent mailbox.
[85486:85486:0407/161502.051577:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[85486:85486:0407/161502.066524:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[85486:85486:0407/161508.928893:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!

(chromium:85454): Gdk-WARNING **: 16:15:13.930: gdk_window_set_user_time called on non-toplevel

I think the error report is ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for XXX times!
Comment by Guoyi (malacology) - Thursday, 07 April 2022, 15:37 GMT
but even I downgrade it, it still exsit
Comment by Jan Alexander Steffens (heftig) - Thursday, 07 April 2022, 17:50 GMT
That's not this bug.

Loading...