Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45902 - lighttpd systemd dependency

Attached to Project: Arch Linux
Opened by Maarten de Vries (de-vri-es) - Wednesday, 05 August 2015, 13:21 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 05 August 2015, 13:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just noticed that lighttpd depends on systemd. Is this dependency really needed?

Running ldd on the executable and all shipped modules suggests the dependency is not needed, but I might have missed something.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 05 August 2015, 13:46 GMT
Reason for closing:  Not a bug
Comment by Maarten de Vries (de-vri-es) - Wednesday, 05 August 2015, 13:26 GMT
Additionally, if lighttpd does need a library shipped by systemd, libsystemd would seem the more logical dependency.
Comment by Maarten de Vries (de-vri-es) - Wednesday, 05 August 2015, 13:33 GMT
Ah, it's because of systemd-tmpfiles in the install script I take it? Bit of a shame that pulls in the entirety of systemd and dependencies. Sorry for the noise.

Loading...