Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#45859 - Makepkg should support whirlpool

Attached to Project: Pacman
Opened by Luke (Gaming4JC) - Friday, 31 July 2015, 21:42 GMT
Last edited by Allan McRae (Allan) - Monday, 14 December 2015, 14:17 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.2.1
Due in Version 5.0.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Since openssl has supported whirlpool for some time and it is faster than SHA512 on larger binaries, I would like to request support for this hashing algorithm. The good news is the patch is extremely simple to do. See below...


Additional info:
* package version(s)
pacman v4.2.1
* config and/or log files etc.
/usr/bin/makepkg


Steps to reproduce:
1) Add whirlpoolsum to your PKGBUILD
2) Add 'whirlpool' to list known_hash_algos in /usr/bin/makepkg.
Should look like this: known_hash_algos=('md5' 'sha1' 'sha224' 'sha256' 'sha384' 'sha512' 'whirlpool')
3) /usr/bin/updpkgsums
4) ??? profit!

Thanks for your consideration. :)
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 14 December 2015, 14:17 GMT
Reason for closing:  Implemented
Additional comments about closing:  git commit 9cdfd187

Loading...