Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45827 - [linuxsampler] upgrade conflicts with package from core

Attached to Project: Community Packages
Opened by Ralf Mardorf (Ralf) - Wednesday, 29 July 2015, 11:05 GMT
Last edited by Ray Rashif (schivmeister) - Monday, 03 August 2015, 07:10 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

community/linuxsampler-2.0.0-1

error: failed to commit transaction (conflicting files)
linuxsampler: /usr/bin/lscp exists in filesystem
linuxsampler: /usr/share/man/man1/lscp.1.gz exists in filesystem
Errors occurred, no packages were upgraded.

$ pacman -Qo /usr/bin/lscp
/usr/bin/lscp is owned by nilfs-utils 2.2.3-1

$ pacman -Qo /usr/share/man/man1/lscp.1.gz
/usr/share/man/man1/lscp.1.gz is owned by nilfs-utils 2.2.3-1

Regards,
Ralf
This task depends upon

Closed by  Ray Rashif (schivmeister)
Monday, 03 August 2015, 07:10 GMT
Reason for closing:  Fixed
Comment by Ray Rashif (schivmeister) - Wednesday, 29 July 2015, 18:03 GMT
Thanks for reporting -- I could not have caught this myself. I think we'll simply rename linuxsampler's lscp, as suggested by prior reports. [1][2]

[1] https://aur.archlinux.org/packages/linuxsampler-svn/
[2] https://bugs.linuxsampler.org/cgi-bin/show_bug.cgi?id=217
Comment by Ray Rashif (schivmeister) - Saturday, 01 August 2015, 10:42 GMT
An update has been pushed. Please confirm things work as expected.
Comment by Ralf Mardorf (Ralf) - Saturday, 01 August 2015, 23:14 GMT
I can confirm that that 50% of the issue are solved.

linuxsampler-2.0.0-2-x86_64
error: failed to commit transaction (conflicting files)
linuxsampler: /usr/share/man/man1/lscp.1.gz exists in filesystem
Comment by Ray Rashif (schivmeister) - Sunday, 02 August 2015, 20:13 GMT
Sorry, my oversight. Should be good to go now with -3. I decided to append the full name of the package to both conflicting files, just to be consistent with naming schemes ('lsampler' does not really say much). Let me know if you disagree.
Comment by Ralf Mardorf (Ralf) - Monday, 03 August 2015, 06:39 GMT
Thank you,

it's fixed.
The names lscp-linuxsampler and lscp-linuxsampler.1.gz are a good choice.
It's possible to launch linuxsampler, jsampler-classic, jsampler 0.9-3 from community and qsampler 0.3.1-1 from aur4. I've got no time to test, if they are working as expected.

Regards,
Ralf

Loading...