Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45779 - [schroot] 'overlay' union-type is not allowed

Attached to Project: Community Packages
Opened by Iwan Briquemont (iwanb) - Sunday, 26 July 2015, 12:00 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 10 March 2016, 18:26 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
schroot allows to use a union fs, but it has a hardcoded list of allowed filesystems.
In Archlinux the overlayfs module is named overlay, which means it fails to match in the hardcoded list.

Possible solutions:
- Add 'overlay' in the hardcoded list upstream
- Patch the code to change 'overlayfs' to 'overlay'
- Rename the overlay module to overlayfs like other distributions

Additional info:

Error when running schroot:
schroot --option=union-type=overlay
E: /etc/schroot/chroot.d/click-ubuntu-sdk-15.04-armhf: line 12 [click-ubuntu-sdk-15.04-armhf] union-type: Unknown filesystem union type ‘overlay’

Function with the check:
lib/schroot/chroot/facet/fsunion.cc-143- void
lib/schroot/chroot/facet/fsunion.cc-144- fsunion::set_union_type (const std::string& type)
lib/schroot/chroot/facet/fsunion.cc-145- {
lib/schroot/chroot/facet/fsunion.cc-146- if (type == "aufs" ||
lib/schroot/chroot/facet/fsunion.cc:147: type == "overlayfs" ||
lib/schroot/chroot/facet/fsunion.cc-148- type == "unionfs" ||
lib/schroot/chroot/facet/fsunion.cc-149- type == "none")
lib/schroot/chroot/facet/fsunion.cc-150- this->union_type = type;
lib/schroot/chroot/facet/fsunion.cc-151- else
lib/schroot/chroot/facet/fsunion.cc-152- throw error(type, FSUNION_TYPE_UNKNOWN);


Steps to reproduce:

Configure a schroot with option union-type=overlay and try to run it, or this command:
schroot --option=union-type=overlay
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 10 March 2016, 18:26 GMT
Reason for closing:  Fixed
Comment by Iwan Briquemont (iwanb) - Sunday, 26 July 2015, 12:04 GMT
Package version:
1.6.10-6

The issue is also present in the upstream launchpad code.
Comment by Iwan Briquemont (iwanb) - Sunday, 26 July 2015, 13:53 GMT
Proposed patch.

There seems to be another related issue, 'mount -t overlay' fails if the workdir option is not given but upperdir is given.
The patch works if you pass the correct mount options using schroot's union-mount-options option.
Comment by Doug Newgard (Scimmia) - Sunday, 26 July 2015, 23:03 GMT
Have you reported this upstream? It's not Arch calling the module this; the upstream in-tree kernel module is called overlay, and it has been since it was merged.
Comment by Iwan Briquemont (iwanb) - Monday, 27 July 2015, 19:35 GMT
Ah ok, I thought this was something Arch specific, it seems to actually be overlayfs that is Debian or Ubuntu specific.
I'll report this upstream then.
Thanks !

Loading...