Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45760 - [xfce4-power-manager](light-locker enabled)Lid close suspend both power states when set for only one

Attached to Project: Arch Linux
Opened by Rob McCathie (korrode) - Friday, 24 July 2015, 11:39 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 13 April 2018, 09:35 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Setting Laptop Lid close action for *either* "On battery" or "Plugged in" to "Suspend" results in suspend action in either power state, even when one state is set to something else.

Discovered initially on Manjaro, confirmed on pure Arch install on my Netbook. (Not that i didn't know Arch would be affected without having to confirm it, but i did anyway to avoid "Arch isn't Manjaro" debates.)


Additional info:
* xfce4-power-manager 1.4.4-1


Upstream bug report:
https://bugzilla.xfce.org/show_bug.cgi?id=12088


Prerequisites to replicate:

Be on a laptop with a lid switch. Ensure lightdm and light-locker are installed, working and the light-locker daemon is running, thus activating xfce4-power-manager's light-locker integration (i.e. the 'Security' tab in xfce4-power-manager's settings window).


To replicate:

In the xfce4-power-manager settings, ensure "Lock screen when system is going for sleep" in the Security tab is enabled.
In the General tab set the "Laptop Lid" action for "On battery" to "Suspend" and the action for "Plugged in" to anything other than Suspend (eg. "Switch off display").
While the laptop is plugged in, close the lid. It should not suspend because we set the action for plugged in to be something other than suspend, but it DOES suspend.



Different ways to fix:


1. Patch settings/xfpm-settings.c to comment line 813.
line 813 at time of report:
xfconf_channel_set_bool (channel, PROPERTIES_PREFIX LOGIND_HANDLE_LID_SWITCH, lock_on_suspend && (lid_switch_on_ac == 1 || lid_switch_on_battery == 1));


2. Patch settings/xfpm-settings.c to change the "||" (or) to "&&" (and) on line 813.


3. Bundle in the xfce4-power-manager package a file: /etc/xdg/xfce/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml
Containing:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-power-manager" version="1.0">
<property name="xfce4-power-manager" type="empty">
<property name="logind-handle-lid-switch" type="bool" value="false" unlocked="root"/>
</property>
</channel>


Solution 3 will not fix the problem for someone running xfce4-power-manager as root, but i'd think this a very rare use case.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 13 April 2018, 09:35 GMT
Reason for closing:  Upstream
Additional comments about closing:  If this is still an issue, it can be tracked upstream.
Comment by Samantha McVey (samcv) - Friday, 10 June 2016, 22:08 GMT
Rob,
The bug tracker page has not had any activity since 2015-10-12, can you please let me know if you are still seeing this bug or not? Your response is greatly appreciated.

Loading...