Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45678 - [speech-dispatcher] breaks pkg-config

Attached to Project: Arch Linux
Opened by Raman Mohan (mohan43u) - Friday, 17 July 2015, 05:55 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Friday, 17 July 2015, 16:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
spech-dispatcher.pc breaks 'pkg-config --list-all' because 'includedir' variable used in 'Cflags' without defining 'includedir'

Steps to reproduce:
'pkg-config --list-all' will throw following error

Variable 'includedir' not defined in '/usr/lib/pkgconfig/speech-dispatcher.pc'

fix:

--- /usr/lib/pkgconfig/speech-dispatcher.pc.corrupted 2015-07-17 13:45:36.750554613 +0800
+++ /usr/lib/pkgconfig/speech-dispatcher.pc 2015-07-17 13:45:43.823887976 +0800
@@ -8,4 +8,4 @@
Version: 0.8.3
Requires: glib-2.0
Libs: -L${libdir} -lspeechd
-Cflags: -I${includedir}
+Cflags: -I${include}
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Friday, 17 July 2015, 16:09 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Friday, 17 July 2015, 06:06 GMT
The pc file comes from upstream, not from Arch. You'd probably be better off reporting this to them.
Comment by Raman Mohan (mohan43u) - Friday, 17 July 2015, 06:16 GMT Comment by Raman Mohan (mohan43u) - Friday, 17 July 2015, 06:37 GMT
Issue in the latest commit (e7684eac8da06acbe3a528d49853cf79abde7dd7) to PKGBUILD.

-- sed -i 's|includedir=.*|include=${prefix}/include/speech-dispatcher|g' "${pkgdir}/usr/lib/pkgconfig/speech-dispatcher.pc"
++ sed -i 's|includedir=.*|includedir=${prefix}/include/speech-dispatcher|g' "${pkgdir}/usr/lib/pkgconfig/speech-dispatcher.pc"
Comment by Doug Newgard (Scimmia) - Friday, 17 July 2015, 06:50 GMT
Ah, I apologize, I missed that.

Loading...