Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45675 - [hydrogen] not listed in Gnome applications. icon is not stored in the correct directory.

Attached to Project: Arch Linux
Opened by Tara Devi (Tara) - Thursday, 16 July 2015, 22:45 GMT
Last edited by Ray Rashif (schivmeister) - Sunday, 02 August 2015, 19:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Icon launcher for hydrogen is not visible in gnome applications.
SVG icon for hydrogen is not in the correct directory.

Additional info:
* package version(s)
hydrogen-0.9.6.1-1-x86_64.pkg.tar.xz

* config and/or log files etc.
n/a

Steps to reproduce:
Install hydrogen
From Gnome, open the application browser and search for the hydrogen application.
The hydrogen application is not listed.

Hydrogen can still be started from the command line or run dialog.

The hydrogen package does contain /usr/share/applications/hydrogen.desktop but Gnome does not seem to recognize it.

Also, though the desktop file seems to reference the h2-icon svg image correctly, the hydrogen package places the icon in /usr/share/hydrogen/data/img/gray/h2-icon.svg instead of /usr/share/icons/hicolor/scalable/apps/h2-icon.svg. I tried copying this icon to the correct directory, updating the icon cache with /usr/bin/gtk-update-icon-cache, and even restarting Gnome but the hydrogen application still did not appear in the applications list.
This task depends upon

Closed by  Ray Rashif (schivmeister)
Sunday, 02 August 2015, 19:34 GMT
Reason for closing:  Fixed
Comment by Ray Rashif (schivmeister) - Tuesday, 28 July 2015, 18:17 GMT
Thanks for reporting. This is actually an upstream issue, but I have edited the path in the meantime as that's the most direct way to solve this. However, please confirm that it works in your DE's menu or file manager.
Comment by Tara Devi (Tara) - Tuesday, 28 July 2015, 20:27 GMT
Thank you.

I just checked in Gnome, Gnome Classic, and Plasma.

Gnome Classic and Plasma list the Hydrogen app in their application launcher.

Gnome (regular) does not list the app. I have no idea why. Maybe at this point it is an upstream issue or a gnome issue?
Comment by Ray Rashif (schivmeister) - Wednesday, 29 July 2015, 06:50 GMT
By "not list the app", do you mean the icon does not show up, or does hydrogen not exist at all? The problem is only in the icon. Since the desktop file exists, any component that shows applications should show it after a desktop database update (which the post-install script does). Could you name me any other similar (audio) app that shows up?
Comment by Tara Devi (Tara) - Saturday, 01 August 2015, 16:59 GMT
All is good now.

The problem was that the application wasn't being listed at all in Gnome. However, with current version 0.9.6.1-2 of the hydrogen package, it was being listed in Gnome on a different laptop that I installed Arch on a month ago.

I just combed through my settings directory and found an old .local/share/applications/hydrogen.desktop file that I had created last year to try to solve the missing app problem. It was overriding the updated hydrogen.desktop file in the current 0.9.6.1-2 version of the hydrogen package. I deleted .local/share/applications/hydrogen.desktop and now the Hydrogen app is correctly listed in the Gnome launcher.

Thank you for your help. :-)

Loading...