Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45635 - [plasma-framework] semi-transparency lost on panels

Attached to Project: Arch Linux
Opened by Jiachen Yang (farseerfc) - Monday, 13 July 2015, 10:44 GMT
Last edited by Antonio Rojas (arojas) - Monday, 13 July 2015, 17:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After I upgraded to plasma-framework 5.12.0-1 , semi-transparency of panels got lost.
The panels and the kickstarter menu no longer show transparent.
Downgraded plasma-framework to 5.11.0-2 solved the problem.


Additional info:
* package version(s)
plasma-framework 5.12.0-1


Steps to reproduce:
1. Update to plasma-framework
2. KDE System Settings > Desktop Behavior > Desktop Effects, Disable "Background contrast".
Semi-transparency of panels got lost after a few seconds.

I uploaded some screenshots to illustrate:
This is how it should be: https://img.vim-cn.com/eb/65da1f44f30301831e232d7d4b0964f7375637.png
This is how it actually shown: https://img.vim-cn.com/df/7203f6737b81de57641cdde381f1c1b38e5c97.png
And this is how it shows after enabled "Background contrast": https://img.vim-cn.com/de/17a98f84dc47559fdad00f49cded4308778f48.png


This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 13 July 2015, 17:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is an upstream design decision
Comment by Ivan P (Soukyuu) - Monday, 13 July 2015, 14:24 GMT
Funny, I searched for "plasma" and "panel" and nothing came up. Oh well.

Some additional info:
- I'm using nvidia proprietary drivers 340xx
- compositing itself is active, as other transparency effects like moving a window around are present
Comment by Antonio Rojas (arojas) - Monday, 13 July 2015, 15:56 GMT
Please report upstream
Comment by Tomasz Cebula (tomaszc) - Monday, 13 July 2015, 16:57 GMT
I reported the error here:
https://bugs.kde.org/show_bug.cgi?id=350184

Please vote for him also on the KDE website.

Loading...