Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#4561 - 0.7.1 setup scripts and modular xorg problem

Attached to Project: Arch Linux
Opened by Random Randolph (aamirtham) - Wednesday, 03 May 2006, 21:59 GMT
Task Type Bug Report
Category Installation
Status Closed
Assigned To No-one
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Since modulizing Xorg, there are two new package groups: "x11-libs" and "x11-drivers".
If I want to install Arch Linux from ftp including the entire "x11-drivers" group, I get the error: "xf86-input-keyboard not present in "x11-drivers" repository"

This is because x11-drivers has a hyphen. The packages group is not stripped in line 660 of the Arch Linux setup script (0.7.1).

line 660 of 'setup':
list=`cat $PKGS | grep "$category/" | sed 's|^[a-z0-9]*/||g' | sed "s|.pkg.tar.gz$| ($category) $tag|g" | sort`

Later in the script pacman will be asked to install the package "x11-drivers/xf86-input-keyboard" instead of "xf86-input-keyboard". It will return a error since there is no repository named "x11-drivers", and no package "xf86-input-keyboard" in that repository.

To fix this, the sed expression has to be enhanced to also allow hyphens in the group name:
list=`cat $PKGS | grep "$category/" | sed 's|^[a-z0-9-]*/||g' | sed "s|.pkg.tar.gz$| ($category) $tag|g" | sort`
This task depends upon

Closed by  Judd Vinet (judd)
Wednesday, 03 May 2006, 23:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Thank you! Fixed for 0.7.2