Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45554 - [linux] kernel 4.1 BCM2046 Bluetooth stopped working

Attached to Project: Arch Linux
Opened by Christian Sigl (subjectdenied) - Saturday, 04 July 2015, 19:51 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 15 July 2015, 21:24 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Evangelos Foutras (foutrelis)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

after upgrading to latest kernel 4.1 in testing, bluetooth module (connected internaly by usb) on my combined broadcom wifi/bt-card doesn't work anymore (wifi is working). bluetoothctl control can't find the "default adapter", subsequently gnome-bluetooth isn't showing any devices. the card is working in latest 4.0.7 kernel

lsusb on kernel 4.0.7:

Bus 002 Device 006: ID 05ac:828d Apple, Inc.
Bus 002 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

on kernel 4.1 i have my non working keyboard and mouse (both apple hardware) showing up in this list too as "Apple Keyboard" and "Apple Mouse", however as mentioned, both do not work

Additional info:
* linux 4.1.1-1 x86_64
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 15 July 2015, 21:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.1.2-2
Comment by Christian Sigl (subjectdenied) - Saturday, 04 July 2015, 20:21 GMT
the exact error on kernel-boot is:

Bluetooth: hci0: BCM: Read verbose config info failed (-16)

bug seems to be confirmed:
https://bugzilla.kernel.org/show_bug.cgi?id=100651
Comment by Evangelos Foutras (foutrelis) - Wednesday, 15 July 2015, 20:44 GMT
Please test if the issue is fixed in linux 4.1.2-2.
Comment by Christian Sigl (subjectdenied) - Wednesday, 15 July 2015, 21:16 GMT
seems to be fixed!

the error is still shown on boot however

Loading...