Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45536 - [ca-certificates-mozilla] 3.19.1-2 breaks eduroam

Attached to Project: Arch Linux
Opened by Tuomo LempiƤinen (Tuxe) - Friday, 03 July 2015, 14:42 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 08 July 2015, 09:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The certificate "Thawte Premium Server CA" seems to have been removed in 3.19.1-2. This breaks logging in to eduroam (at least in my university).

Steps to reproduce:

1. Update ca-certificates-mozilla to 3.19.1-2 or newer.
2. Try to use eduroam with an Aalto Univeristy account.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 08 July 2015, 09:56 GMT
Reason for closing:  Not a bug
Comment by Jens Adam (byte) - Sunday, 05 July 2015, 19:33 GMT
Well, it's a 1024-bit (totally deprecated) root certificate with a SHA1 (deprecated) signature, so not much of a surprise.
Integrate the cert yourself: https://www.thawte.com/roots/thawte_Premium_Server_CA.pem
Not a bug.

Loading...