Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45535 - [vim] latest version inserting g character upon opening file

Attached to Project: Arch Linux
Opened by Jeremy M. (jskier) - Friday, 03 July 2015, 13:31 GMT
Last edited by Anatol Pomozov (anatolik) - Thursday, 28 January 2016, 13:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Since upgrading vim today on x86_64 and arm, it appears to insert a 'g' character upon opening an existing file. The 'g' shows up throughout document in random places, forcing corruption of source and config files if saved.

Additional info:
* 7.4.764-1
* Using included vimrc example
* Also impacts arm, have not confirmed i686


Steps to reproduce:
* vim file, save, quit
* vim file
* Observe the 'g' character inserted; screen shot attached
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Thursday, 28 January 2016, 13:44 GMT
Reason for closing:  Upstream
Comment by Jeremy M. (jskier) - Friday, 03 July 2015, 13:34 GMT
Additional research, this appears to work fine in putty, and may be related to cygwin terminal.
Comment by homy (h8h) - Saturday, 04 July 2015, 14:30 GMT
  • Field changed: Percent Complete (100% → 0%)
I've also have this issue on urxvt terminals, but not on vte (lxterminal) terminals and not on rxvt terminals.

Maybe its some unicode issue.

@edit
its not unicode related as far as I figured out yet and sorry I didn't read that issue carefully enough, for me there is no g inserted in vim, there are some other chars: :d999/d2d1/6968/8786[>85;95;0.

There is also a thread about that issue with a patch, i think:
https://bbs.archlinux.org/viewtopic.php?pid=1542084#p1542084
Comment by Simon Tunnat (simontunnat) - Sunday, 05 July 2015, 12:26 GMT
Like mentioned in the thread the bug is caused by transparent backgrounds.
After removing the line "urxvt.background: [80]#000000" from my Xressources file vim worked as intended again.

Version 7.4.766 might be fixing the bug (see: https://groups.google.com/forum/#!topic/vim_dev/dyVf-CWLlSI). Because I'm still compiling it I can't say for sure jet.

EDIT:
7.4.766 does not fix the problem.
Comment by Jeremy M. (jskier) - Tuesday, 07 July 2015, 13:24 GMT
Going back to an older version (7.4.729-1) and the problem is not present.

Edit: I only tested with cygwin terminal and only for the 'g' character.
Comment by Anatol Pomozov (anatolik) - Saturday, 11 July 2015, 21:39 GMT
Please try the latest version 7.4.778
Comment by Jeremy M. (jskier) - Sunday, 12 July 2015, 12:34 GMT
Appears to work for me using Cygwin Terminal to x86_64 and arm hosts with version 7.4.778.
Comment by homy (h8h) - Sunday, 12 July 2015, 12:46 GMT
It also appears to work for me, too. (version 7.4.778)
Comment by PCFreak (pcfreak) - Tuesday, 14 July 2015, 22:07 GMT
  • Field changed: Percent Complete (100% → 0%)
using a remote terminal (MobaXTerm, a windows application) and the problem still appears with 7.4.778-1.
I can workarround it by applying a vim colorscheme.
I could not workarround with a .XResources file since I don't have one.

It seems only workarrounds help but it is not really fixed.
Comment by Anatol Pomozov (anatolik) - Tuesday, 14 July 2015, 22:14 GMT
Please report this issue to upstream maillist https://groups.google.com/forum/#!forum/vim_dev Thanks.
Comment by PCFreak (pcfreak) - Wednesday, 15 July 2015, 06:20 GMT
sent a mail to the above list!
Comment by PCFreak (pcfreak) - Wednesday, 15 July 2015, 07:28 GMT
Comment by Anatol Pomozov (anatolik) - Wednesday, 27 January 2016, 04:27 GMT
I believe this bug has been fixed in the recent builds. Please confirm it.
Comment by PCFreak (pcfreak) - Thursday, 28 January 2016, 06:41 GMT
From my point of view it seems to works Will further investigate that and if it appears again will post it here.

Loading...