Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#45531 - [rawtherapee] Missing gtk-engines dependency

Attached to Project: Community Packages
Opened by Justin Dray (justin8) - Friday, 03 July 2015, 05:59 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 08 September 2017, 15:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Jirkovsky (6xx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Missing dependency on gtk-engines. Without this the default theme won't render correctly (light grey text on white background, etc) and GTK warnings are printed out:
(rawtherapee:23288): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
1. Install rawtherapee
2. Test (
3. Install gtk-engines
4. Retest (
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 08 September 2017, 15:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed, then the fix was removed so presumably it was also fixed upstream
Comment by Lukas Jirkovsky (6xx) - Monday, 06 July 2015, 06:32 GMT
It must be something else, as I don't have gtk-engines installed and rawtherapee looks correct.
Comment by Justin Dray (justin8) - Monday, 06 July 2015, 06:47 GMT
Hmm, I was getting those gtk-warning errors, and as soon as I installed gtk-engines (and no other dependencies) it stopped the errors and the UI displayed correctly. And uninstalling it just now has the same exact results. Is there anything else I could test?
Comment by Lukas Jirkovsky (6xx) - Monday, 06 July 2015, 07:13 GMT
I tried to remove all gtk themes I had installed (I had only oxygen-gtk2) except for the Raleigh that's bundled with GTK2 and I'm still not able to reproduce the problem. Can you try fiddling with the "Default Theme" settings in the rawtherapee preferences? It may be some combination with the theme you are using and the rawtherapee themes that breaks it,
Comment by Justin Dray (justin8) - Monday, 06 July 2015, 09:15 GMT
I hadn't thought of changing my system wide theme, but if I select use system theme, it uses the system theme as expected without issues. It's only the internal theme that is broken without gtk-engines installed. Please see here:
Comment by Justin Dray (justin8) - Monday, 06 July 2015, 09:16 GMT
I can replicate it on a different archlinux install in a VM as well. Same as in the video.
Comment by Lukas Jirkovsky (6xx) - Wednesday, 15 July 2015, 16:41 GMT
What desktop environment/window manager are you using? I tried it with a new user under OpenBox and on my laptop and still no luck reproducing the problem.
Comment by Justin Dray (justin8) - Wednesday, 15 July 2015, 16:52 GMT
I'm using gnome 3. It happens with the default adwaita theme as well.
Comment by Lukas Jirkovsky (6xx) - Monday, 20 July 2015, 19:45 GMT
Bingo! It seems Gnome 3 is the culprit. It works everywhere else, but it breaks under gnome. I can't tell whether it's bug in Gnome or Rawtherapee though, but given the fact it works elsewhere, my bets are it's gnome at fault.
Comment by Lukas Jirkovsky (6xx) - Monday, 20 July 2015, 20:08 GMT
I've added gtk-engines to optdepends for now.
Comment by Justin Dray (justin8) - Monday, 20 July 2015, 21:00 GMT
Ahh, that is really odd. Thanks for the update though.
Comment by Eli Schwartz (eschwartz) - Wednesday, 09 August 2017, 05:10 GMT
rawtherapee 1:5.0.1-1 removed this optdepends, does that mean this is no longer a problem?