Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45502 - [subversion] needs rebuild for perl 5.22

Attached to Project: Arch Linux
Opened by Miguel de Val-Borro (migueldvb) - Monday, 29 June 2015, 17:09 GMT
Last edited by Felix Yan (felixonmars) - Thursday, 24 September 2015, 10:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Angel Velasquez (angvp)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

subversion needs to be rebuilt

Additional info:
* package version(s) 1.8.13
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Felix Yan (felixonmars)
Thursday, 24 September 2015, 10:41 GMT
Reason for closing:  Upstream
Additional comments about closing:  fixed in subversion 1.9.2-1
Comment by Miguel de Val-Borro (migueldvb) - Monday, 29 June 2015, 22:30 GMT
I think this is not a subversion bug, please close the ticket.
Comment by Kyle MacLeod (kmacleod) - Wednesday, 08 July 2015, 14:52 GMT
I'm seeing issues when using 'git svn rebase'. I think it's because the subversion perl modules need to be rebuilt.

I'm basing that on the output of the find-broken-perl-packages.sh script found via https://lists.archlinux.org/pipermail/arch-dev-public/2014-June/026359.html.

The output of that script lists the following.

%cat pacman.txt
subversion

% cat perl-modules.txt
SVN::_Client
SVN::_Wc
SVN::_Ra
SVN::_Fs
SVN::_Delta
SVN::_Core
SVN::_Repos

% cat raw.txt
/usr/lib/perl5/vendor_perl/auto/SVN/_Client/_Client.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Wc/_Wc.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Ra/_Ra.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Fs/_Fs.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Delta/_Delta.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Core/_Core.so
/usr/lib/perl5/vendor_perl/auto/SVN/_Repos/_Repos.so

Comment by Doug Newgard (Scimmia) - Wednesday, 08 July 2015, 14:52 GMT
What version of the subversion package?
Comment by Kyle MacLeod (kmacleod) - Wednesday, 08 July 2015, 14:59 GMT
pacman -Qs subversion
local/subversion 1.8.13-2

pacman -Qs perl
...
local/perl 5.22.0-1 (base)

It's strange because I can see from the package build dates that subversion 1.8.13-2 was built at 2015-06-03 06:31 UTC, and perl 5.22.0-1 was built at 2015-06-02 07:48 UTC.

I'm coming at this from git-svn failing on svn operations, like:

% git svn rebase
Current branch master is up to date.
error: git-svn died of signal 11

I'm pretty sure it tracks back to the perl 5.22 update.
Comment by Kyle MacLeod (kmacleod) - Wednesday, 08 July 2015, 15:35 GMT
I rebuilt subversion manually using abs/makepkg and there is no difference.
find-broken-perl-packages.sh is still complaining about the SVN perl modules.
Comment by Miguel de Val-Borro (migueldvb) - Wednesday, 08 July 2015, 16:35 GMT
I had the same problem with git-svn. In the end I removed some perl packages that I have installed from the AUR
and were built with perl 5.20 and git-svn works normally. It is strange because these packages are not required by
the git-svn utility.
Comment by Kyle MacLeod (kmacleod) - Wednesday, 08 July 2015, 17:36 GMT
So I guess maybe this is a git-svn issue. I see how find-broken-perl-packages.sh is probably reporting a false positive caused by the '_' in the .so module name.
Comment by Roman Kosenko (kite) - Thursday, 13 August 2015, 16:49 GMT
I have tried to rebuild subversion without damn patches and without all shit stuff (gnome, java, kde, etc.) - only plain subversion and perl bindings. It works now for me without segfault. :)
Comment by Felix Yan (felixonmars) - Friday, 14 August 2015, 02:13 GMT
Can you try to disable only "subversion.rpath.fix.patch" and see if the problem goes?
Comment by Roman Kosenko (kite) - Friday, 14 August 2015, 08:42 GMT
I don't want to install all this stuff (gnome, kde, etc.) and I don't even know how to download snapshot tar-ball with all these files for PKGBUILD (like in AUR) without cloning whole repo or clicking every file, sorry. Why don't you try by yourself?
Comment by Roman Kosenko (kite) - Friday, 14 August 2015, 09:25 GMT
I have tried to build with "subversion.rpath.fix.patch" - it works fine, so problem is not in this patch.
Comment by Kyle MacLeod (kmacleod) - Monday, 17 August 2015, 18:28 GMT
Hi Felix, I just rebuilt with the patch command for subversion.rpath.fix.patch commented out in prepare(). Still seeing the issue.
Let me know if there's anything else I can try.
Comment by Kyle MacLeod (kmacleod) - Thursday, 24 September 2015, 10:27 GMT
This has now gone away with subversion 1.9.2-1, git 2.5.3-1. It was the subversion update that fixed it.
Comment by Felix Yan (felixonmars) - Thursday, 24 September 2015, 10:40 GMT
Thanks for the info!

Loading...