Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#4549 - error messages while/after install a package with pacman

Attached to Project: Pacman
Opened by Stefano (kki) - Tuesday, 02 May 2006, 14:38 GMT
Last edited by Roman Kyrylych (Romashka) - Saturday, 18 November 2006, 14:11 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

----
[root@L0cutus ~]# pacman -S gvim-devel
:: gvim-devel-7.0f-1: is up to date. Upgrade anyway? [Y/n]

Targets: gvim-devel-7.0f-1

Total Package Size: 1.8 MB

Proceed with upgrade? [Y/n]

checking package integrity... done.
loading package data... done.
checking for file conflicts... done.
recovering symlink names and binaries...done
upgrading gvim-devel... done.
updating desktop and mime database...

** (process:10682): CRITICAL **: egg_desktop_entries_add_group: assertion `egg_desktop_entries_lookup_group (entries, group_name) == NULL' failed
moving symlinks to make vim binary more capable...done
----
obviously other packages have same problem (not all !)

any idea on how to fix this ?
Thaks
This task depends upon

Closed by  Aaron Griffin (phrakture)
Monday, 20 November 2006, 18:27 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This, if anything, is upstream. As stated, it appears to be an invalid desktop entry found when regenerating the desktop stuff for gnome.
Comment by Jens Adam (byte) - Tuesday, 02 May 2006, 20:42 GMT
You could reinstall desktop-file-utils, delete the .cache files in the application/ directories , find the offending entry in a .desktop file, run 'update-desktop-database -v' ... must be something in that region.
Comment by Not Important (pholie) - Monday, 22 May 2006, 12:08 GMT
I did:
$ cd /usr/share/applications/
$ for pac in `ls -1 /usr/share/applications/` ; do desktop-file-validate $pac; done;

and here is what I get. It seems that lot of .desktop files contain some bad info:

GNUDoku.desktop: error: required key "Encoding" not found
amule.desktop: warning: the fields "Name" and "Comment" have the same value
base.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
bmpx.desktop: error: file has "Desktop Action" sections but no Action key
calc.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
cube.desktop: error: required key "Encoding" not found
cube.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
draw.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
elinks.desktop: error: required key "Encoding" not found
elinks.desktop: warning: file contains key "TerminalOptions", usage of this key is not recommended, since it has been deprecated
gftp.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility
gnome-screensaver-properties.desktop: error: required key "Encoding" not found
impress.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
keytouch.desktop: error: required key "Encoding" not found
keytouch.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
linuxdcpp.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
math.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
mimeinfo.cache: parse error: Error in section MIME Cache at line 2: Invalid characters in key name
mozilla-firefox.desktop: warning: non-standard key "MultipleArgs" lacks the "X-" prefix
mplayer.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility
nmapfe.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
opera.desktop.pholie: error: value of key "Categories" is a list of strings and must end with a semicolon
seamonkey.desktop: warning: non-standard key "MultipleArgs" lacks the "X-" prefix
template.desktop: warning: non-standard key "MultipleArgs" lacks the "X-" prefix
template.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility
writer.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
xine.desktop: error: required key "Encoding" not found
xine.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility



At least those packages with errors should be fixed, maybe it will make the "CRITICAL **: egg_desktop_entries_add_group" errors disappear.
Comment by Cesar Alcalde (noalwin) - Sunday, 04 June 2006, 21:28 GMT
I was doing a pacman -Suy after adding the testing repo and I get a couple of errors like.

** (process:17171): CRITICAL **: egg_desktop_entries_add_group: assertion `egg_desktop_entries_lookup_group (entries, group_name) == NULL' failed

The packages that seems to do that are ekiga 2.0.1-4 and vlc 0.8.5-4

---------------------------------------------------------------------------
I reinstaled desktop-file-utils und ran update-desktop-database -v which gives me a los of messages like

File '/opt/xfce4/share/applications/Xfdiff.desktop' lacks MimeType key

In the output I also see :

File '/opt/kde/share/applications/kde/knetload.desktop' lacks MimeType key
File '/opt/kde/share/applications/kde/kboincspy.desktop' lacks MimeType key

** (process:17185): CRITICAL **: egg_desktop_entries_add_group: assertion `egg_desktop_entries_lookup_group (entries, group_name) == NULL' failed
File '/opt/kde/share/applications/kde/kdmtheme.desktop' lacks MimeType key
File '/opt/xfce4/share/applications/Xfsamba.desktop' lacks MimeType key

---------------------------------------------------------------------

The $ cd /usr/share/applications/ $ for pac in `ls -1 /usr/share/applications/` ; do desktop-file-validate $pac; done; gives me

amsn.desktop: warning: non-standard key "Info" lacks the "X-" prefix
amule.desktop: warning: the fields "Name" and "Comment" have the same value
azureus.desktop: error: required key "Encoding" not found
base.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
calc.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
cups.desktop: warning: file contains key "TerminalOptions", usage of this key is not recommended, since it has been deprecated
draw.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
impress.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
kcmgtk-xdg.desktop: warning: file contains key "Keywords", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
kcmgtk-xdg.desktop: error: file contains multiple assignments of key "Terminal"
math.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"
mimeinfo.cache: parse error: Error in section MIME Cache at line 2: Invalid characters in key name
mozilla-firefox.desktop: warning: non-standard key "MultipleArgs" lacks the "X-" prefix
mplayer.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility
nmapfe.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
template.desktop: warning: non-standard key "MultipleArgs" lacks the "X-" prefix
template.desktop: warning: boolean key "Terminal" has value "0", boolean values should be "false" or "true", although "0" and "1" are allowed in this field for backwards compatibility
twinkle.desktop: error: required key "Encoding" not found
twinkle.desktop: error: value of key "Categories" is a list of strings and must end with a semicolon
writer.desktop: warning: file contains key "InitialPreference", this key is currently reserved for use within KDE, and should in the future KDE releases be prefixed by "X-"

-------------------------------------------------------------------------------------

Ekiga and vlc seems to work correctly. Sorry for my bad english.
Comment by Roman Kyrylych (Romashka) - Wednesday, 15 November 2006, 20:07 GMT
Status of this bug? Is this a _bug_ at all?

Loading...