Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45472 - [efibootmgr] Could not set variable: Invalid argument

Attached to Project: Arch Linux
Opened by Please Delete (balticer) - Thursday, 25 June 2015, 20:01 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 20 July 2015, 05:51 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

not working anymore after upgrade to version efibootmgr-0.12-1-x86_64. got following error while trying to add new boot entry:

efibootmgr: Could not set variable: Invalid argument
efibootmgr: Could not prepare boot variable: Invalid argument

no errors with previous version efibootmgr-0.11.0-1-x86_64.

regards
Kai
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 20 July 2015, 05:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  efivar 0.21-1
Comment by Michael Heyns (beanaroo) - Friday, 26 June 2015, 04:33 GMT
I can confirm same error.

efibootmgr-0.11.0-1-x86_64 works as expected. Command used is:

# efibootmgr -d /dev/sda -p 1 -c -L "Arch Linux" -l /vmlinuz-linux -u "root=/dev/sda2 rw initrd=/initramfs-linux.img"

Comment by Leif Warner (pdxleif) - Friday, 26 June 2015, 22:11 GMT
Same results w/ efibootmgr 0.12-1, here.
Comment by Nicolas Dudebout (dudebout) - Saturday, 27 June 2015, 01:32 GMT
Same error and downgrading does work.
Comment by Please Delete (balticer) - Monday, 29 June 2015, 17:07 GMT
I reported it to upstream here: https://github.com/rhinstaller/efibootmgr/issues/36
because of same issue reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1232491

regards
Comment by Justin Capella (justincapella) - Monday, 20 July 2015, 04:41 GMT
This is fixed in efivar-0.21-1

Loading...