Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45459 - [mesa] video using VA-API slow and freeze system with 10.6.0-1

Attached to Project: Arch Linux
Opened by Tomasz Cebula (tomaszc) - Wednesday, 24 June 2015, 19:04 GMT
Last edited by Laurent Carlier (lordheavy) - Sunday, 11 October 2015, 12:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

After upgrading to mesa 10.6.0-1 under the Intel Graphics, with the work of the VA-API display slows down and freezes.

Additional info:

* package version(s)
mesa 10.6.0-1
mesa-libgl 10.6.0-1

* config and/or log files etc.
System: 4.0.6-1-ck x86_64 (64 bit), (tested also 4.0.5-2), Desktop: KDE (Plasma 5.3)
CPU: Dual core Intel Core i5 M 450 (-HT-MCP-) cache: 3072 KB
Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.Org 1.17.2 driver: intel Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 10.6.0

This is the first generation of Intel Core also tested on the second and fourth generation and it works properly.

Steps to reproduce:

Metod 1
- install mesa 10.6.0-1 and mesa-libgl 10.6.0-1
- install mpv and configure it:
vo=opengl
hwdec=vaapi
- play any video,

Metod 2
- install mesa 10.6.0-1 and mesa-libgl 10.6.0-1
- install kodi
- enable VA-API (Settings > Video > Acceleration)
- play any video

Symptoms: display slows down and freezes

Tested on:
- xf86-video-intel 1:2.99.917+364+gb24e758-1 and 2.99.917-5
- AccelMethod, SNA, UXA, glamor
- Linux 4.0.6 and 4.0.5-2

It helps only downgrade to mesa and mesa-libgl to 10.5.7-1

Does not help downgrade xf86-video-intel to 2.99.917-5, therefore the suspicion that the problem is mesa.

A similar problem:
https://bbs.archlinux.org/viewtopic.php?id=198982
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Sunday, 11 October 2015, 12:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa-11.0.3-1
Comment by Tomasz Cebula (tomaszc) - Thursday, 25 June 2015, 08:38 GMT
"This is the first generation of Intel Core also tested on the second and fourth generation and it works properly."

Will correct:
The problem is on Intel Core i5 M 450 - first generation (Nehalem) of Intel Core, also tested on the i3-3220T - third generation (Ivy Bridge) and i3-4005U fourth generation (Haswell) and it works properly.
I did not test for second-generation (Sandy Bridge).
Comment by Tomasz Cebula (tomaszc) - Thursday, 25 June 2015, 18:09 GMT
On most video files you can see the problem, but not all.
You can test to: Jellyfish Video Bitrate Test Files http://jell.yfish.us/
Comment by Alexander Kempen (chron) - Monday, 29 June 2015, 20:17 GMT
---
Comment by Tomasz Cebula (tomaszc) - Tuesday, 30 June 2015, 19:37 GMT
Mesa 10.6.1 does not resolve this bug.
Comment by UroŇ° Vampl (Gusar) - Tuesday, 30 June 2015, 20:30 GMT
Anyone reported this to mesa upstream? Bugs don't magically fix themselves, developers need to be told about them.

In the meantime, does vo=vaapi work? It's a better option than opengl anyway, it uses less resources. The advantage of opengl is the high quality stuff (vo=opengl-hq), but even here vo=vaapi:scaling=hq provides something very similar, but with less resource usage. See here for a test I did: https://github.com/mpv-player/mpv/issues/1765#issuecomment-91191085
Comment by Tomasz Cebula (tomaszc) - Wednesday, 08 July 2015, 09:20 GMT
>In the meantime, does vo=vaapi work?
No,

The bug is reported here:
https://bugs.freedesktop.org/show_bug.cgi?id=91254
Comment by Tomasz Cebula (tomaszc) - Thursday, 09 July 2015, 05:52 GMT
Until the release of the next version of the mesa, I have a request for maintainers to recompile mesa with reverse patch:
https://git.thm.de/tjkl80/mesa/commit/0e0e23ef537c9add672ff322f34e129a07edc55e.patch

More information at:
https://bugs.freedesktop.org/show_bug.cgi?id=91254

I tested and it works correctly, if anyone needs it attach ready PKGBUILD
   PKGBUILD (6.6 KiB)
Comment by Tomasz Cebula (tomaszc) - Sunday, 12 July 2015, 20:33 GMT
In 10.6.2 is the same bug.
This patch also works with 10.6.2, or you can ask for the imposition of a package maintainer?
Comment by Tomasz Cebula (tomaszc) - Sunday, 11 October 2015, 12:43 GMT

Loading...